Bug 124495 - Installer hangs with an agpgart error repeating forever
Installer hangs with an agpgart error repeating forever
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
2
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
http://www.supermicro.com/products/mo...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-05-26 19:57 EDT by Scott Baker
Modified: 2015-01-04 17:06 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-04-16 01:21:02 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Scott Baker 2004-05-26 19:57:28 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7)
Gecko/20040514

Description of problem:
I have a Penguin Computing server that's running FC1 flawlessly right
now. I wanted to blow it away and install FC2 on it. I was using the
boot CD to install it over the network and as you hit enter at the
lilo (?) boot screen it starts loading the kernel gets to a line where
it allocates AGP memory and then it prints:

"agpgart: posted write buffer flush took morethen 3 seconds"

About a million times on the screen. I've retried the installer using
noagp and I still get the agp error. I search the FAQ and the errata
as well as BugZilla and could find almost no reference to this error
at all. Google only had a dozen or so hits and most were links to the
agpgart source.

Version-Release number of selected component (if applicable):
Whatever kernel the installer uses I'm not sure

How reproducible:
Always

Steps to Reproduce:
1. Burn Boot CD
2. Boot up system with boot CD
3. Hit "enter" at the boot screen to boot the kernel
4. *poof* agpgart error!
5. profit!
    

Actual Results:  It loads about 2 pages worth of Kernel messages and
gets to a section where it allocates AGP memory and spits out

agpgart: posted write buffer flush took morethen 3 seconds

a million times.

Expected Results:  It should have launched the regular installer

Additional info:

Here's some system specs, I'm not sure if they're helpful or not. I
can provide more if required.

:lspci -v
00:00.0 Host bridge: ServerWorks CNB20HE Host Bridge (rev 23)
        Flags: fast devsel
        Memory at fa000000 (32-bit, prefetchable) [disabled] [size=32M]
        Memory at <ignored> (32-bit, non-prefetchable) [disabled]
[size=4K]

00:00.1 PCI bridge: ServerWorks CNB20LE Host Bridge (rev 01) (prog-if
00 [Normal decode])
        Flags: bus master, 66Mhz, medium devsel, latency 64
        Bus: primary=00, secondary=01, subordinate=01, sec-latency=64
        I/O behind bridge: 0000b000-0000bfff
        Memory behind bridge: fc500000-fe5fffff
        Prefetchable memory behind bridge: fc200000-fc2fffff
        Capabilities: [80] AGP version 2.0

00:00.2 Host bridge: ServerWorks: Unknown device 0006 (rev 01)
        Flags: medium devsel

00:00.3 Host bridge: ServerWorks: Unknown device 0006 (rev 01)
        Flags: medium devsel

00:04.0 Ethernet controller: Intel Corp. 82557/8/9 [Ethernet Pro 100]
(rev 08)
        Subsystem: Intel Corp. EtherExpress PRO/100+ Server Adapter
(PILA8470B)
        Flags: bus master, medium devsel, latency 64, IRQ 5
        Memory at feafd000 (32-bit, non-prefetchable) [size=4K]
        I/O ports at d400 [size=64]
        Memory at fe800000 (32-bit, non-prefetchable) [size=1M]
        Capabilities: [dc] Power Management version 2

00:06.0 Ethernet controller: Intel Corp. 82557/8/9 [Ethernet Pro 100]
(rev 08)
        Subsystem: Intel Corp. EtherExpress PRO/100+ Server Adapter
(PILA8470B)
        Flags: bus master, medium devsel, latency 64, IRQ 9
        Memory at feafe000 (32-bit, non-prefetchable) [size=4K]
        I/O ports at d800 [size=64]
        Memory at fe900000 (32-bit, non-prefetchable) [size=1M]
        Capabilities: [dc] Power Management version 2

00:0f.0 ISA bridge: ServerWorks OSB4 South Bridge (rev 50)
        Subsystem: ServerWorks OSB4 South Bridge
        Flags: bus master, medium devsel, latency 0

00:0f.1 IDE interface: ServerWorks OSB4 IDE Controller (prog-if 8a
[Master SecP PriP])
        Flags: bus master, medium devsel, latency 64
        I/O ports at ffa0 [size=16]

00:0f.2 USB Controller: ServerWorks OSB4/CSB5 OHCI USB Controller (rev
04) (prog-if 10 [OHCI])
        Subsystem: ServerWorks OSB4/CSB5 OHCI USB Controller
        Flags: bus master, medium devsel, latency 64, IRQ 10
        Memory at feaff000 (32-bit, non-prefetchable) [size=4K]

01:00.0 VGA compatible controller: ATI Technologies Inc Rage XL AGP 2X
(rev 27) (prog-if 00 [VGA])
        Subsystem: ATI Technologies Inc Xpert 98 RXL AGP 2X
        Flags: bus master, stepping, medium devsel, latency 64, IRQ 11
        Memory at fd000000 (32-bit, non-prefetchable) [size=16M]
        I/O ports at b800 [size=256]
        Memory at fe5ff000 (32-bit, non-prefetchable) [size=4K]
        Expansion ROM at fe5c0000 [disabled] [size=128K]
        Capabilities: [50] AGP version 1.0
        Capabilities: [5c] Power Management version 2
Comment 1 Dave Jones 2004-05-27 07:15:58 EDT
we poke a value into a pci register, and try and read it back.
3 seconds later, it still wasn't the value we wrote into the register.

If your BIOS has any options like 'pci posted writes' and the like,
try turning them off.  It's very odd that this code works on FC1 but
doesn't in FC2, as the logic hasn't changed at all afaik.
Comment 2 Scott Baker 2004-05-27 12:21:28 EDT
I couldn't find a "pci posted writes" but I did find "memory write
posting" and "agp operations" both of which I disabled and I still get
that error and the system hangs.

I updated the BIOS as well, still no luck. Heck I even tried "lost
failsafe defaults" in the BIOS still with no luck. Rebooted and loaded
FC1 just fine. If it helps anyone the motherboard is a SuperMicro 370DER.

Anything else I should be trying?
Comment 3 Bill Vinson 2004-05-30 10:33:24 EDT
I am experiencing the same issue with the exact same motherboard.  I thought I had a bug 
filed on it here, but can't find it.  No BIOS settings seem to have any effect.

Anything I can do to assist in tracking this down?
Comment 4 Dave Jones 2004-06-01 03:51:51 EDT
ok, bug found. this driver was trying to be too clever for its own good.
Fix will go to Linus today, and should show up in the FC2 update kernel.
Comment 5 Gorazd M. 2004-06-12 12:16:43 EDT
Hi.

I got the same problem. Is this fix released yet or how can i get
updated CD with this new kernel ? 
Comment 6 Walter Coria 2004-06-17 12:49:11 EDT
Same Problem on a Supermicro 370DER+ ... system hang on install
AGPGART Error loop.
Haven't seen any release of fix for this. So my Dual Xeon Server sits 
quietly. Installed fine on P4 2.5ghz ASUS.

Tried update on the BIOS... no killjoy
Setting within the bios useless. 

Hope there is a fix ... would hate to wait for FC3

Comment 7 Dave Jones 2004-06-17 13:57:16 EDT
can you try the update kernel from http://people.redhat.com/arjanv/2.6
on FC1 (you'll need to boot with vdso=0).
That should have this fixed hopefully.
Comment 8 Scott Baker 2004-06-17 14:14:01 EDT
How can I use that kernel, if I can't even get the OS installed?
Comment 9 Dave Jones 2004-06-17 14:34:05 EDT
you don't still have FC1 installed as you mentioned in comment #1 ?

if we can prove this works, we can generate another boot.iso as we did
for the VIA C3 & ASUS P4P800 bugs. It's a bit of hoop-jumping, but
it'll  work so you can get FC2 installed.  But first we need to know
if the problem is fixed or not, otherwise the creation of the boot.iso
is pointless (and its not a trivial amount of work to build one).
Comment 10 Scott Baker 2004-06-17 14:42:01 EDT
Unfortunately that server is in use for the time being (running FC1)
and can't be rebooted. That should change shortly and I can test
again. Perhaps you should contact the other two posters on this bug
that are getting the same error I am.

Once I get services moved off my server I'll be able to test as well.
Either next week, or the week after.
Comment 11 Bill Vinson 2004-06-21 02:55:58 EDT
Sorry, I have been out of town, but I just tried to test this and it looks to fail.  Here are the 
steps I went through in case any adjustments need to be made to properly test the new 
kernel.

I have just downloaded and installed a minimal FC1.  No updates were applied.  I installed 
http://people.redhat.com/arjanv/2.6/RPMS.kernel/kernel-2.6.7-1.441.i686.rpm and 
rebooted.  I switched to the new kernel, edited it, changed the kernel line to include 
vdso=0 at the end.  It displays the AGP initialization and then seems to hang.  No "posted 
write buffer" messages appear, but it goes no further in the boot process.

Let me know what I can do to help.  I will leave this system at base FC1 for the time being 
so that more testing can be done...

Thanks,
Bill
Comment 12 Bill Curry 2004-06-22 12:46:31 EDT
I have several of these motherboards not in production all exhibit the same behavior 
described in this report.  I can do any testing as needed 
Comment 13 Bill Curry 2004-06-24 16:56:01 EDT
Testing update.

Installed Fedora Core 1 on SuperMicro 370DER motherboard.
Compiled 2.6.7 kernel without agpgart support.
System booted without any problems.
Comment 14 Walter Coria 2004-06-24 20:06:58 EDT
Well Bill, yes FC1 installs fine ... with AGPGART ... I did not 
exclude AGPGART on the first install. However FC2 does not install.
At this point it looks like I'll have to install FC1 and then 
upgrade. Although I hear upgrading is not really a good idea. 
There probably will not be a new release out just for this problem. 
As I'm sure you all now... the needs of the many outweigh the needs 
of the few.
Comment 15 Jason Tibbitts 2004-08-12 13:02:14 EDT
I'm in the same boat with teh same board; I have no current OS
installation and don't have FC1 around.  Is there any information on
building a custom boot image so that I can get this machine going?
Comment 16 Jason Tibbitts 2004-08-12 15:11:13 EDT
Scratch that; I managed to get things working by using the current
rawhide initrd.img, vmlinuz and netstg2.img.  I had to boot with
agp=off to avoid a hard hang but otherwise it's working fine.  The
installed system is plain FC2 with all updates applied.
Comment 17 Scott Baker 2004-11-01 12:14:19 EST
I just tried installed FC3T3 on this motherboard and now the error
message doesn't loop forever, but it does lock up. Has anyone tried
install FC3 on this 370DER motherboard? Did you have the same results?
Comment 18 Jason Tibbitts 2004-11-01 12:33:39 EST
You don't say whether you tried booting with agp=off as mentioned in
the comment directly above yours.  It was required for me to boot FC3T1.
Comment 19 Stuart Highlander 2004-12-03 08:33:43 EST
I am in the same boat with the same board.  System is currently 
running FC1 with no problems, but when I try to upgrade to FC2 using 
the CD-ROMs, I get the same error.  I really need to upgrade this box 
to FC2.  Can anybody tell me how this can be accomplished?
Comment 20 Scott Baker 2004-12-03 19:05:01 EST
The server with this particular motherboard was just freed up, and
thus I had a chance to try and install FC3 on it. It appears it is
possible to boot now if you pass the agp=off during the install boot
process.
Comment 21 Stuart Highlander 2004-12-13 10:54:54 EST
I have tried to install Core 2 and Core 3 by passing the agp=off 
during the install boot process.  The message does not loop forever, 
but locks up.  Please advise.
Comment 22 Dave Jones 2004-12-13 11:04:39 EST
I must admit, I'm incredibly puzzled why agp=off didnt do the trick in
fc3 (it was broken in fc2)  Do you still see agpgart messages with
that  switch? does it hang at the same place ?
Comment 23 Stuart Highlander 2004-12-13 11:29:19 EST
At the boot line I type "linux agp=off"  When it gets to "agpgart: 
posted write buffer flush took morethen 3 seconds"  the boot process 
hangs.  The motherboard is supermicro mentioned above.

Comment 24 Dave Jones 2004-12-13 11:54:37 EST
ok, found a bug where we still tried to do a chipset initialisation
even if we passed agp=off. I'll fix this up.
Comment 25 Stuart Highlander 2004-12-17 09:47:09 EST
is the problem just with the kernel of the installer or is it 
problematic with subsequent kernels?  am i totally off base?
Comment 26 Dave Jones 2004-12-17 12:27:11 EST
there is no seperate 'installer kernel' these days, so it affects
every kernel.
Comment 27 Stuart Highlander 2005-01-04 16:40:18 EST
Does the 2.6.9-1.11_FC2 or 2.6.9-1.11_FC2 kernel released yesterday 
address this problem?  If so, is there a quick and dirty way to make 
a boot disk (either floppy or cdrom) to where I can upgrade my FC1 
server to either FC2 or FC3? 
Comment 28 Dave Jones 2005-04-16 01:21:02 EDT
Fedora Core 2 has now reached end of life, and no further updates will be
provided by Red Hat.  The Fedora legacy project will be producing further kernel
updates for security problems only.

If this bug has not been fixed in the latest Fedora Core 2 update kernel, please
try to reproduce it under Fedora Core 3, and reopen if necessary, changing the
product version accordingly.

Thank you.

Note You need to log in before you can comment on or make changes to this bug.