Bug 1244969 - rhel-osp-director: HA deployment with SSL enabled: unable to save glance images.
Summary: rhel-osp-director: HA deployment with SSL enabled: unable to save glance images.
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: python-rdomanager-oscplugin
Version: unspecified
Hardware: x86_64
OS: Linux
high
high
Target Milestone: ga
: Director
Assignee: Brad P. Crochet
QA Contact: Alexander Chuzhoy
URL:
Whiteboard:
Depends On: 1244913
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-07-20 22:25 UTC by Alexander Chuzhoy
Modified: 2015-08-05 14:00 UTC (History)
7 users (show)

Fixed In Version: python-rdomanager-oscplugin-0.0.8-42.el7ost
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-08-05 14:00:01 UTC
Target Upstream Version:


Attachments (Terms of Use)
logs from controller1 (537.17 KB, application/x-gzip)
2015-07-20 22:30 UTC, Alexander Chuzhoy
no flags Details
logs from controller2 (561.78 KB, application/x-gzip)
2015-07-20 22:30 UTC, Alexander Chuzhoy
no flags Details
logs from controller3 (540.09 KB, application/x-gzip)
2015-07-20 22:30 UTC, Alexander Chuzhoy
no flags Details


Links
System ID Priority Status Summary Last Updated
Gerrithub.io 240668 None None None Never
Red Hat Product Errata RHEA-2015:1549 normal SHIPPED_LIVE Red Hat Enterprise Linux OpenStack Platform director Release 2015-08-05 17:49:10 UTC

Description Alexander Chuzhoy 2015-07-20 22:25:27 UTC
rhel-osp-director: HA deployment with SSL enabled: unable to save glance images.

Environment:
instack-undercloud-2.1.2-21.el7ost.noarch
python-glance-2015.1.0-6.el7ost.noarch
openstack-glance-2015.1.0-6.el7ost.noarch
python-glanceclient-0.17.0-2.el7ost.noarch
python-glance-store-0.4.0-1.el7ost.noarch


Steps to reproduce:
1. Install undercloud and enable SSL.
2. Deploy overcloud with HA.
3. Attempt to create glance image with:
glance image-create --name cirros --disk-format qcow2 --container-format bare --is-public 1 --copy-from https://launchpad.net/cirros/trunk/0.3.0/+download/cirros-0.3.0-x86_64-disk.img

Result:
The image isn't saved. Running "glance image-list" shows status "saving" and it doesn't change over time.


Expected result:
The image should be saved and ready to use.

Comment 3 Alexander Chuzhoy 2015-07-20 22:27:27 UTC
I verified this works on another HA setup without SSL.

Comment 4 Alexander Chuzhoy 2015-07-20 22:30:12 UTC
Created attachment 1054065 [details]
logs from controller1

Comment 5 Alexander Chuzhoy 2015-07-20 22:30:29 UTC
Created attachment 1054066 [details]
logs from controller2

Comment 6 Alexander Chuzhoy 2015-07-20 22:30:46 UTC
Created attachment 1054067 [details]
logs from controller3

Comment 7 James Slagle 2015-07-21 11:15:24 UTC
did you successfully deploy an overcloud? that would mean that glance in the undercloud is working fine, so I'm not sure how this would be related to undercloud SSL at all.

to confirm, are you trying to load images into the overcloud glance when you encounter this issue? The attached logs don't show any errors, so that's why I'm wondering if you're trying to load images into the undercloud or overcloud glance.

Could it be that the overcloud nodes can't access https://launchpad.net/cirros/trunk/0.3.0/+download/cirros-0.3.0-x86_64-disk.img to download the image?

Comment 8 Alexander Chuzhoy 2015-07-21 12:54:26 UTC
The overcloud was deployed successfully.

I'm trying to load the image to the overcloud - double checked that.
In he messages file in the tarbal, there're lots of glance-registry errors. Are they related?

I'm able to wget the image, but when I tried to add the image from file:

glance image-create --name cirros --disk-format qcow2 --container-format bare --is-public 1 --file cirros-0.3.0-x86_64-disk.img
Error finding address for http://10.19.184.180:9292/v1/images: [Errno 32] Broken pipe

Comment 9 James Slagle 2015-07-21 14:57:25 UTC
the issue here turned out to be that a previous deployment done with ceph had updated the GlanceBackend parameter in tuskar to be rbd. In a subsequent deployment without ceph, that parameter never gets reset in Tuskar, so glance is still configured with default_store=rbd, which was breaking the image saving.

there is fix in progress for this issue as part of:
https://bugzilla.redhat.com/show_bug.cgi?id=1244913

Comment 11 Alexander Chuzhoy 2015-07-28 18:13:43 UTC
Verified:
Environment:
instack-undercloud-2.1.2-22.el7ost.noarch
python-rdomanager-oscplugin-0.0.8-43.el7ost.noarch


The reported issue doesn't reproduce. The image changes its status to "active".

Comment 13 errata-xmlrpc 2015-08-05 14:00:01 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2015:1549


Note You need to log in before you can comment on or make changes to this bug.