Bug 1244972 - [abrt] eclipse-pydev: init_libpycomps(): python2.7 killed by SIGSEGV
Summary: [abrt] eclipse-pydev: init_libpycomps(): python2.7 killed by SIGSEGV
Status: CLOSED DEFERRED
Alias: None
Product: Fedora
Classification: Fedora
Component: eclipse-pydev
Version: 22
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Alexander Kurtakov
QA Contact: Fedora Extras Quality Assurance
URL: https://retrace.fedoraproject.org/faf...
Whiteboard: abrt_hash:33042d4b45f75dd9319316181c4...
Keywords:
: 1288639 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-07-20 22:40 UTC by laolux
Modified: 2016-06-28 14:03 UTC (History)
6 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2016-06-27 06:42:55 UTC


Attachments (Terms of Use)
File: backtrace (107.32 KB, text/plain)
2015-07-20 22:40 UTC, laolux
no flags Details
File: cgroup (190 bytes, text/plain)
2015-07-20 22:40 UTC, laolux
no flags Details
File: core_backtrace (10.84 KB, text/plain)
2015-07-20 22:40 UTC, laolux
no flags Details
File: dso_list (46.06 KB, text/plain)
2015-07-20 22:40 UTC, laolux
no flags Details
File: environ (2.71 KB, text/plain)
2015-07-20 22:40 UTC, laolux
no flags Details
File: limits (1.29 KB, text/plain)
2015-07-20 22:40 UTC, laolux
no flags Details
File: maps (220.54 KB, text/plain)
2015-07-20 22:40 UTC, laolux
no flags Details
File: mountinfo (3.64 KB, text/plain)
2015-07-20 22:40 UTC, laolux
no flags Details
File: namespaces (85 bytes, text/plain)
2015-07-20 22:40 UTC, laolux
no flags Details
File: open_fds (701 bytes, text/plain)
2015-07-20 22:40 UTC, laolux
no flags Details
File: proc_pid_status (966 bytes, text/plain)
2015-07-20 22:40 UTC, laolux
no flags Details
File: var_log_messages (313 bytes, text/plain)
2015-07-20 22:40 UTC, laolux
no flags Details

Description laolux 2015-07-20 22:40:01 UTC
Description of problem:
I opened an old working directory with a new version of eclipse.
During the update process this warning about a crash of eclipse-pydev came up, but the instalation seems to have comleted successfully.

Version-Release number of selected component:
eclipse-pydev-4.0.0-2.fc22

Additional info:
reporter:       libreport-2.6.0
backtrace_rating: 4
cmdline:        /usr/bin/python2.7 -u /usr/lib64/eclipse/dropins/pydev-core/eclipse/plugins/org.python.pydev_4.0.0.201505131500/pysrc/pycompletionserver.py 55154
crash_function: init_libpycomps
executable:     /usr/bin/python2.7
global_pid:     7130
kernel:         4.0.8-300.fc22.x86_64
runlevel:       N 5
type:           CCpp
uid:            1000

Truncated backtrace:
Thread no. 1 (10 frames)
 #0 init_libpycomps at /usr/src/debug/libcomps-e11ff1b16f901139ee4e9d6ccc9219982ceaebd5/libcomps/src/python/src/pycomps.c:1038
 #1 _PyImport_LoadDynamicModule at /usr/src/debug/Python-2.7.10/Python/importdl.c:53
 #2 load_module at /usr/src/debug/Python-2.7.10/Python/import.c:1919
 #3 import_submodule at /usr/src/debug/Python-2.7.10/Python/import.c:2704
 #4 load_next at /usr/src/debug/Python-2.7.10/Python/import.c:2519
 #5 import_module_level at /usr/src/debug/Python-2.7.10/Python/import.c:2228
 #6 PyImport_ImportModuleLevel at /usr/src/debug/Python-2.7.10/Python/import.c:2292
 #7 builtin___import__ at /usr/src/debug/Python-2.7.10/Python/bltinmodule.c:49
 #8 PyObject_Call at /usr/src/debug/Python-2.7.10/Objects/abstract.c:2529
 #9 PyEval_CallObjectWithKeywords at /usr/src/debug/Python-2.7.10/Python/ceval.c:3981

Potential duplicate: bug 1107994

Comment 1 laolux 2015-07-20 22:40:05 UTC
Created attachment 1054068 [details]
File: backtrace

Comment 2 laolux 2015-07-20 22:40:06 UTC
Created attachment 1054069 [details]
File: cgroup

Comment 3 laolux 2015-07-20 22:40:07 UTC
Created attachment 1054070 [details]
File: core_backtrace

Comment 4 laolux 2015-07-20 22:40:09 UTC
Created attachment 1054071 [details]
File: dso_list

Comment 5 laolux 2015-07-20 22:40:10 UTC
Created attachment 1054072 [details]
File: environ

Comment 6 laolux 2015-07-20 22:40:11 UTC
Created attachment 1054073 [details]
File: limits

Comment 7 laolux 2015-07-20 22:40:14 UTC
Created attachment 1054074 [details]
File: maps

Comment 8 laolux 2015-07-20 22:40:15 UTC
Created attachment 1054075 [details]
File: mountinfo

Comment 9 laolux 2015-07-20 22:40:16 UTC
Created attachment 1054076 [details]
File: namespaces

Comment 10 laolux 2015-07-20 22:40:17 UTC
Created attachment 1054077 [details]
File: open_fds

Comment 11 laolux 2015-07-20 22:40:18 UTC
Created attachment 1054078 [details]
File: proc_pid_status

Comment 12 laolux 2015-07-20 22:40:19 UTC
Created attachment 1054079 [details]
File: var_log_messages

Comment 13 Mat Booth 2015-07-21 08:55:48 UTC
Is this reproducable?

It would really help us if you could attach some sample workspace that exhibits the problem.

Comment 14 laolux 2015-07-31 08:49:58 UTC
I tried to create a couple of example workspaces with older versions of eclipse which I expected to have the same behavior, but have not been able to recreate the problem. Next time I will try with a fresh fedora install.

Comment 15 Alexander Kurtakov 2016-06-17 12:50:31 UTC
So you can not reproduce it now?

Comment 16 laolux 2016-06-18 10:01:36 UTC
No, it won't crash on my test machine.
I have since upgraded all my systems to Fedora 23, so maybe just close the bug.

Comment 17 Alexander Kurtakov 2016-06-27 06:42:55 UTC
Closing the bug as per previous comment.

Comment 18 Mat Booth 2016-06-28 14:03:11 UTC
*** Bug 1288639 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.