This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 124498 - Autofs should be restarted when firstboot is ready
Autofs should be restarted when firstboot is ready
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: authconfig (Show other bugs)
2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Tomas Mraz
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-05-26 20:14 EDT by Tuomas Haarala
Modified: 2007-11-30 17:10 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-12-13 12:29:47 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Tuomas Haarala 2004-05-26 20:14:06 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040510

Description of problem:
After the network authentication has been selected, autofs should be
restarted (made aware of new automounter maps). If this isn't done,
users logging in with, for example, NIS accounts won't have home
directory mounted.


Version-Release number of selected component (if applicable):
1.3.14-1

How reproducible:
Always

Steps to Reproduce:
1. Install the system
2. Configure NIS authentication with firstboot
3. Try to log in as user
    

Actual Results:  Network authenticated account didn't have home
directory mounted after the system was configured.

Expected Results:  Network authenticated account should have home
directory after the system is configured.

Additional info:
Comment 1 Brent Fox 2004-06-14 14:57:41 EDT
Firstboot calls authconfig-gtk to do the NIS configuration.  It seems
to me that authconfig-gtk should contain the code to restart autofs if
necessary instead of firstboot.
Comment 2 Jindrich Novy 2004-08-26 09:17:07 EDT
authconfig-gtk restarts automatically all the following services if
they exist in /etc/init.d/<service>, --firstboot is its argument and
changes are confirmed by pressing OK:

firstbootservices = [
	"autofs",
	"dovecot",
	"messagebus",
	"postfix",
	"privoxy",
	"radiusd",
	"rstatd",
	"rusersd",
	"rwalld",
	"rwhod",
	"saslauthd",
	"sendmail",
	"smb",
	"squid",
	"sshd",
	"vncserver",
	"vsftpd",
	"winbind"
]

The autofs is present in the list so I think the problem is somewhere
else here ... 

greetings,
Jindrich
Comment 4 Joe Orton 2004-12-13 12:14:17 EST
Does it also run "nscd -i <blah>" to invalidate the passwd and group
caches in a running nscd daemon?  I just hit a similar problem where
nscd had cached negative entries for users so even after restarting
the relevant service (sshd), I could log in.  Restarting nscd was
necessary.
Comment 5 Tomas Mraz 2004-12-13 12:28:43 EST
If restarting nscd is enough to invalidate the caches then yes, it
restarts nscd after writing configuration files.
Comment 6 Tomas Mraz 2004-12-13 12:29:47 EST
Fixed in FC3.

Note You need to log in before you can comment on or make changes to this bug.