Bug 1245159 - [Director] external vlan network with network isolation doesn't work
Summary: [Director] external vlan network with network isolation doesn't work
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tuskar
Version: Director
Hardware: Unspecified
OS: Unspecified
unspecified
urgent
Target Milestone: ga
: Director
Assignee: Dan Sneddon
QA Contact: Ofer Blaut
URL:
Whiteboard:
Depends On:
Blocks: 1250251
TreeView+ depends on / blocked
 
Reported: 2015-07-21 10:49 UTC by Ofer Blaut
Modified: 2015-08-05 14:00 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 1250251 (view as bug list)
Environment:
Last Closed: 2015-08-05 14:00:04 UTC
Target Upstream Version:


Attachments (Terms of Use)
commands and logs (7.31 KB, text/plain)
2015-07-21 10:49 UTC, Ofer Blaut
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2015:1549 normal SHIPPED_LIVE Red Hat Enterprise Linux OpenStack Platform director Release 2015-08-05 17:49:10 UTC

Description Ofer Blaut 2015-07-21 10:49:56 UTC
Created attachment 1054290 [details]
commands and logs

Description of problem:

I have a setup of BM with network isolation and bonds.

my external network is using vlan and it doesn't work.

The problem is the L3 agent.ini was configured with external_network_bridge = br-ex

see attached logs 

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.install BM setup with network isolation 
2. create external network with vlan , and router

source keystonerc_admin ; neutron net-create ext_net --provider:network_type vlan --provider:physical_network datacentre --provider:segmentation_id xxx --router:external
source keystonerc_admin ; neutron subnet-create ext_net --allocation-pool start=10.x.x.110,end=10.x.x.130 --gateway 10.x.x.254 --cidr 10.x.x.0/24 --enable_dhcp=False

3. ping external gw from nets and see if it works 

Actual results:

ping to external gw doesn't work 

Expected results:


Additional info:

workaround :

1. edit network-environment.yaml  and add:

parameters:
  Controller-1::NeutronExternalNetworkBridge: "''"

2. deploy 

If you alreday installed 

1. run on ALL controllers : sudo openstack-config --set /etc/neutron/l3_agent.ini DEFAULT external_network_bridge

2. pcs resource disable neutron-l3-agent
3. pcs resource enable neutron-l3-agent
4. create your networks

Comment 3 Ofer Blaut 2015-07-21 10:52:37 UTC
(In reply to Ofer Blaut from comment #0)
> Created attachment 1054290 [details]
> commands and logs
> 
> Description of problem:
> 
> I have a setup of BM with network isolation and bonds.
> 
> my external network is using vlan and it doesn't work.
> 
> The problem is the L3 agent.ini was configured with external_network_bridge
> = br-ex
> 
> see attached logs 
> 
> Version-Release number of selected component (if applicable):
> 
> 
> How reproducible:
> 
> 
> Steps to Reproduce:
> 1.install BM setup with network isolation 
> 2. create external network with vlan , and router
> 
> source keystonerc_admin ; neutron net-create ext_net --provider:network_type
> vlan --provider:physical_network datacentre --provider:segmentation_id xxx
> --router:external
> source keystonerc_admin ; neutron subnet-create ext_net --allocation-pool
> start=10.x.x.110,end=10.x.x.130 --gateway 10.x.x.254 --cidr 10.x.x.0/24
> --enable_dhcp=False
> 
> 3. ping external gw from nets and see if it works 
> 
> Actual results:
> 
> ping to external gw doesn't work 

external_network_bridge =  
must be the default value 
> 
> Expected results:
> 
> 
> Additional info:
> 
> workaround :
> 
> 1. edit network-environment.yaml  and add:
> 
> parameters:
>   Controller-1::NeutronExternalNetworkBridge: "''"
> 
> 2. deploy 
> 
> If you alreday installed 
> 
> 1. run on ALL controllers : sudo openstack-config --set
> /etc/neutron/l3_agent.ini DEFAULT external_network_bridge
> 
> 2. pcs resource disable neutron-l3-agent
> 3. pcs resource enable neutron-l3-agent
> 4. create your networks

Comment 10 Dan Prince 2015-08-04 13:58:40 UTC
I thought we specifically changed this upstream already to fix Tuskar:

http://git.openstack.org/cgit/openstack/tripleo-heat-templates/tree/environments/net-bond-with-vlans.yaml#n19

---

If that fix isn't working perhaps you could revert parameter_defaults: back to just parameters: because that definitely works when using Heat directly (via --templates).

Comment 14 errata-xmlrpc 2015-08-05 14:00:04 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2015:1549


Note You need to log in before you can comment on or make changes to this bug.