Bug 124518 - xterm -into and -e options don't work together
Summary: xterm -into and -e options don't work together
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: xterm
Version: 3.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jason Vas Dias
QA Contact:
URL:
Whiteboard: RHEL3U7NAK
Depends On:
Blocks: 187539
TreeView+ depends on / blocked
 
Reported: 2004-05-27 05:58 UTC by James Armstrong
Modified: 2007-11-30 22:07 UTC (History)
2 users (show)

Fixed In Version: RHBA-2006-0422
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-05-10 21:30:06 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2006:0422 normal SHIPPED_LIVE xterm bug fix update 2006-07-19 20:40:00 UTC

Description James Armstrong 2004-05-27 05:58:13 UTC
Description of problem:

xterm will not honor -e option if -into option is used.

Version-Release number of selected component (if applicable):
xterm-179-5.EL

How reproducible:
Every Time.

Steps to Reproduce: Enter:
1.wish
2.toplevel .ac -container 1
3.exec xterm -into [expr [winfo id .ac ] ] -e vim &

(the expr above has the effect of converting the window ID from hex
notation to decimal.)
  
Actual results:

As if you only did

exec xterm -into [expr [winfo id .ac ] ]

Expected results:

Would like to see vim in the window.

Additional info:
The "break" on line 1966 should be a "continue" like all previous
options except "e".  The "break" makes sense for the "e" option
because, as documented, it must be the last option if it is used. 

        case 'i':
            if (argc <= 1) {
                Syntax(*argv);
            } else {
                char *endPtr;
                --argc;
                ++argv;
                winToEmbedInto = (Window) strtol(argv[0], &endPtr, 10);
            }
            break;   <<< Make this continue;
 

I've tested this fix on fedora where it is also needed.

Comment 1 James Armstrong 2004-05-27 06:00:08 UTC
The above code snippet refers to main.c

Comment 2 Thomas E. Dickey 2004-05-29 11:40:38 UTC
That's a useful bug report, but (I should add it to my FAQ),
Redhat rarely forwards them upstream.  Having said that, there's
no reason for Mike Harris to paste in the boilerplate comment
that you will note in most of the other reports for xterm.

Comment 3 Mike A. Harris 2004-06-02 06:14:01 UTC
Hi Thomas,

The fix above appears to be correct after a preliminary review of
the option processing.  I'll add the patch to my next xterm build,
if you approve the fix.  I'm going to be doing a few erratum soon
for FC1, and could add in xterm as well, since it is such a simple
fix.

Thanks guys!

Comment 4 Thomas E. Dickey 2004-06-02 21:20:29 UTC
the fix looks right to me, too.

Comment 5 Thomas E. Dickey 2004-06-09 23:10:54 UTC
I added this fix to xterm #191

Comment 6 Mike A. Harris 2004-06-11 18:46:27 UTC
Queued fix for next xterm build for RHEL3.

Thanks guys.

Comment 7 Mike A. Harris 2004-06-18 22:18:49 UTC
Updated xterm to version 191 in rawhide for FC3.

Patch still queued for future RHEL3 update.

Comment 14 Mike A. Harris 2005-06-29 17:53:55 UTC
Fixed in xterm-179-5.EL.1, scheduled for potential inclusion in RHEL3U6.

Setting status to MODIFIED.

Comment 27 Red Hat Bugzilla 2006-05-10 21:30:06 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2006-0422.html



Note You need to log in before you can comment on or make changes to this bug.