Bug 1245425 - IFS is not set back after used as "[" in log_newer function of include.rc
Summary: IFS is not set back after used as "[" in log_newer function of include.rc
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: tests
Version: mainline
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Pranith Kumar K
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: 1316436
TreeView+ depends on / blocked
 
Reported: 2015-07-22 04:13 UTC by Fang Huang
Modified: 2016-06-16 13:25 UTC (History)
3 users (show)

Fixed In Version: glusterfs-3.8rc2
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 1316436 (view as bug list)
Environment:
Last Closed: 2016-06-16 13:25:33 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Fang Huang 2015-07-22 04:13:43 UTC
Description of problem:

In log_newer function, IFS is set to "[". It should be set back before the function return. This causes the last cleanup in basic/afr/self-heald.t to create a diretory "/d/backends\ /mnt/glusterfs/0\ /mnt/glusterfs/1\ /mnt/glusterfs/2\ /mnt/nfs/0\ /mnt/nfs/1/".

The following is part of the log file. The bash shell add single quotes to the variable WORKDIRS

+ umount -l /mnt/nfs/1
+ umount -f /mnt/nfs/1
+ true
+ rm -rf '/d/backends /mnt/glusterfs/0 /mnt/glusterfs/1 /mnt/glusterfs/2 /mnt/nfs/0 /mnt/nfs/1'
+ leftover=
+ for d in '$WORKDIRS'
+ test -d '/d/backends /mnt/glusterfs/0 /mnt/glusterfs/1 /mnt/glusterfs/2 /mnt/nfs/0 /mnt/nfs/1'
+ '[' x '!=' x ']'
+ mkdir -p '/d/backends /mnt/glusterfs/0 /mnt/glusterfs/1 /mnt/glusterfs/2 /mnt/nfs/0 /mnt/nfs/1'
+ return 0
+ exit


Version-Release number of selected component (if applicable):

3.7.2

How reproducible:

always

Steps to Reproduce:
1. ./run-tests ./test/basic/afr/self-heald.t
2. ls /d
backends  backends 

Actual results:

Two directories "backends  backends " are shown.

Expected results:

only one "backends" directory exits.

Additional info:

Comment 1 Anand Avati 2015-07-28 13:54:51 UTC
REVIEW: http://review.gluster.org/11779 (tests: reset IFS after changing it) posted (#1) for review on master by Pranith Kumar Karampuri (pkarampu@redhat.com)

Comment 2 Anand Avati 2015-07-30 09:59:29 UTC
REVIEW: http://review.gluster.org/11779 (tests: reset IFS after changing it) posted (#2) for review on master by Pranith Kumar Karampuri (pkarampu@redhat.com)

Comment 3 Raghavendra Talur 2016-03-10 09:21:03 UTC
Fang Huang,

If you waiting for this fix to come in glusterfs test packages. Please follow 3.7 releasse bug: 1316436.

Comment 4 Niels de Vos 2016-06-16 13:25:33 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.8.0, please open a new bug report.

glusterfs-3.8.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://blog.gluster.org/2016/06/glusterfs-3-8-released/
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user


Note You need to log in before you can comment on or make changes to this bug.