Bug 1245485 - Web UI gets javascript error that crashes browser when viewing tasks
Summary: Web UI gets javascript error that crashes browser when viewing tasks
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Satellite
Classification: Red Hat
Component: Tasks Plugin
Version: 6.0.4
Hardware: Unspecified
OS: Unspecified
unspecified
high vote
Target Milestone: Unspecified
Assignee: Ivan Necas
QA Contact: Corey Welton
URL: http://projects.theforeman.org/issues...
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-07-22 07:32 UTC by Ivan Necas
Modified: 2019-06-13 21:25 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-10-15 18:20:26 UTC
Target Upstream Version:


Attachments (Terms of Use)
initial load of subtasks page, while repos are syncing (76.00 KB, image/png)
2015-10-02 21:20 UTC, Corey Welton
no flags Details
reload of subtasks page in different browser tab, showing completed syncs. (90.85 KB, image/png)
2015-10-02 21:21 UTC, Corey Welton
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Foreman Issue Tracker 11092 0 None None None 2016-04-22 16:26:27 UTC
Red Hat Product Errata RHBA-2015:1911 0 normal SHIPPED_LIVE Satellite 6.1.3 bug fix update 2015-10-15 22:19:19 UTC

Description Ivan Necas 2015-07-22 07:32:01 UTC
Complete steps from beginning to end to reproduce (Firefox browser):

1)Create a product
2)setup multiple external repos for that product
3)do a mass sync (I had 4 repos updating in this case) which will cause a parent task with subtasks to get created.
4)click on the tasks tab for the product.
5)Click the sub-tasks link which will bring you to the subtasks page (screenshot attached).
6)Wait for the page to reload and watch the errors start.

As you can see in the latest linked example, on the first reload, I get 3 copies of the menu bar, on the subsequent reloads, the entire screen fills up as linked in the first post.

Original report for reference : https://groups.google.com/forum/#!topic/foreman-users/hcHmr70IdJY

Screenshots attached.

Comment 1 Ivan Necas 2015-07-22 07:32:03 UTC
Created from redmine issue http://projects.theforeman.org/issues/11092

Comment 4 Ivan Necas 2015-07-29 12:52:40 UTC
Fix merged into master https://github.com/theforeman/foreman-tasks/pull/126

Comment 8 Corey Welton 2015-10-02 21:19:33 UTC
So I'm not sure how we consider this fully fixed, necessarily?  At very least, need some clarification.

The steps above read:

6)Wait for the page to reload and watch the errors start.

As it stands, once I go to the subtasks page, I never, ever see another reload.  I attempted to sync six repos, and within the subtasks page, all of them showed up as "running"; "pending".  This never, ever changes however.  If I take the URL and open a new tab, I can plainly see that the sync has completed, so I interpret this as meaning the refresh on this page has been completely removed?

Is this the intended fix/result - that refresh on the page is totally removed, in order keep the redraw from occurring?  Or am I missing something?

If the former is the solution, it feels like a "hack", but I don't want to be hasty in assuming that. 

Attaching two screenshots - one showing the page, five+ minutes after sync initiated, never updating, and a second with the page reloaded in a different browser tab, showing completion.

Comment 9 Corey Welton 2015-10-02 21:20:31 UTC
Created attachment 1079522 [details]
initial load of subtasks page, while repos are syncing

Comment 10 Corey Welton 2015-10-02 21:21:58 UTC
Created attachment 1079523 [details]
reload of subtasks page in different browser tab, showing completed syncs.

  Please note that original tab never refreshe(s|d), showing things pending/running in perpetuity.

Comment 11 Corey Welton 2015-10-02 21:23:46 UTC
TL;DR: Should we expect the page to refresh (minus the broken menu bars) as the repos sync?  The bug seems to imply that, but the fix seems to remove any reloads altogether.

Comment 12 Ivan Necas 2015-10-05 07:57:32 UTC
On the tasks list page, the reloads were not implemented, both before and after applying the patches for this fix. This is regarding the task details page only.

Comment 13 Corey Welton 2015-10-05 20:02:46 UTC
So, on the individual task details page, I see refresh, and the menu longer keeps getting generated.  I suppose we can mark this verified.

Satellite-6.1.0-RHEL-7-20151002.0 compose

Comment 15 errata-xmlrpc 2015-10-15 18:20:26 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2015:1911


Note You need to log in before you can comment on or make changes to this bug.