Bug 1245559 - Failed to create postgresql objects due to "mysql" already exists
Summary: Failed to create postgresql objects due to "mysql" already exists
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Image
Version: 3.0.0
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: ---
Assignee: Jason DeTiberus
QA Contact: Gaoyun Pei
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-07-22 09:52 UTC by chunchen
Modified: 2016-09-30 02:16 UTC (History)
7 users (show)

(edit)
Attempting to use the default PostgreSQL database service templates after using a default MySQL template failed with errors reporting "mysql" already exists. This was due to an incorrect value in the PostgreSQL templates, which has now been fixed.
Clone Of:
(edit)
Last Closed: 2015-08-03 20:17:43 UTC


Attachments (Terms of Use)
snapshot for creating postgresql on web console (117.54 KB, image/png)
2015-07-22 09:53 UTC, chunchen
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2015:1540 normal SHIPPED_LIVE Red Hat OpenShift Enterprise 3.0.1.0 bug fix and enhancement update 2015-08-04 00:17:18 UTC

Description chunchen 2015-07-22 09:52:52 UTC
Description of problem:
It's failed to create postgresql objects due to "mysql" already exists.

Version-Release number of selected component (if applicable):
oc v3.0.1.0-388-g51e9da7
kubernetes v1.0.0

How reproducible:
100%

Steps to Reproduce:
1. Login to the web console
2. Create mysql objects via selecting mysql template like "mysql-persistent"
3. Try to create postresql object via selecting postgresql template like "postgresql-ephemeral"

Actual results:
please check the snapshot in attachment

Expected results:
The name should not be "mysql" for postgresql objects on web console.

Additional info:

Comment 1 chunchen 2015-07-22 09:53:53 UTC
Created attachment 1054768 [details]
snapshot for creating postgresql on web console

Comment 4 Jessica Forrester 2015-07-30 13:57:58 UTC
This was a problem with the template and was fixed in this commit https://github.com/openshift/origin/commit/ff76077ed68a7c36a8f0ceab20bcf78e22ad87da

Comment 5 chunchen 2015-07-31 06:12:21 UTC
Checked against latest OSE env(openshift v3.0.1.0-525-geddc479, kubernetes v1.0.0), the issue is fixed, so mark it as verified.

Comment 7 errata-xmlrpc 2015-08-03 20:17:43 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2015:1540


Note You need to log in before you can comment on or make changes to this bug.