Bug 124573 - Autofs mount through symlink causes kernel oops
Autofs mount through symlink causes kernel oops
Status: CLOSED DUPLICATE of bug 118413
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
2
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jeff Moyer
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-05-27 12:51 EDT by Patrick Caldon
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:03:50 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Patrick Caldon 2004-05-27 12:51:16 EDT
Description of problem:

Attempting to mount an nfs filesystem through autofs and symbolic link
causes oops. The filesystem is on the other side of an ipsec tunnel,
with ipsec turned off (so the other side of the tunnel is
inaccessible).  On attempting to do a listing of the directory linked
to, an oops occurs. 

Version-Release number of selected component (if applicable):

kernel-2.6.5-1.358

How reproducible:


Steps to Reproduce:
1. Fresh install of fedora 2
2. insert pcmcia wireless card and ifconfig/defualt route to something
3. *DONT* turn on ipsec - thus other side is silently dropping packets
4. symbolic link exists from /home/mandy/lily-home to
/net/lily/home/mandy; lily is on the other side of the tunnel 
5.  ls -l /home/mandy/lily-home
  
Actual results:

May 28 02:07:27 localhost kernel: Badness in interruptible_sleep_on at
kernel/sched.c:1927
May 28 02:07:27 localhost kernel: Call Trace:
May 28 02:07:27 localhost kernel:  [<0227ee1e>]
interruptible_sleep_on+0x5a/0xa7May 28 02:07:27 localhost kernel: 
[<02115e97>] default_wake_function+0x0/0xc
May 28 02:07:27 localhost kernel:  [<0e912267>]
autofs4_wait+0x1c6/0x200 [autofs4]
May 28 02:07:27 localhost kernel:  [<0e911576>]
try_to_fill_dentry+0x39/0xdb [autofs4]
May 28 02:07:27 localhost kernel:  [<0214af60>] do_lookup+0x54/0x72
May 28 02:07:27 localhost kernel:  [<0214b494>] link_path_walk+0x516/0x6e2
May 28 02:07:27 localhost kernel:  [<0214b8b3>] path_lookup+0xf8/0x128
May 28 02:07:27 localhost kernel:  [<0214b9ef>] __user_walk+0x21/0x51
May 28 02:07:27 localhost kernel:  [<02147d39>] vfs_lstat+0x11/0x37
May 28 02:07:27 localhost kernel:  [<0213777f>] do_mmap_pgoff+0x4cf/0x604
May 28 02:07:27 localhost kernel:  [<02148297>] sys_lstat64+0xf/0x23
May 28 02:07:27 localhost kernel:  [<021413d7>] vfs_read+0xdc/0xe4
May 28 02:07:27 localhost kernel:  [<02114408>] do_page_fault+0x0/0x446
May 28 02:07:28 localhost kernel:
M

Expected results:

Not that!

Additional info:

Wireless card is avaya ...
Comment 1 Jeff Moyer 2004-05-27 13:08:07 EDT
Additional Comment #1 From Arjan van de Ven (arjanv@redhat.com)  on
2004-05-23 02:45 -------

you might want to try the update candidate kernel from
http://people.redhat.com/arjanv/2.6/



*** This bug has been marked as a duplicate of 118413 ***
Comment 2 Red Hat Bugzilla 2006-02-21 14:03:50 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.