Bug 124574 - Use poll() instead of select() in rpmio.c
Use poll() instead of select() in rpmio.c
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: rpm (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jeff Johnson
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-05-27 12:51 EDT by Tom "spot" Callaway
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-05-29 12:01:05 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
use poll() instead of select() in rpmio.c (1.58 KB, patch)
2004-05-27 12:51 EDT, Tom "spot" Callaway
no flags Details | Diff

  None (edit)
Description Tom "spot" Callaway 2004-05-27 12:51:26 EDT
Since the 2.6 kernel for Linux/Sparc64 seems to have issues with
select(), I've converted it to poll(). 

The attached patch makes the core changes, but you probably will want
to wrap it with an autoconf check, since poll() is not the most
portable thing known to mankind. :)
Comment 1 Tom "spot" Callaway 2004-05-27 12:51:57 EDT
Created attachment 100635 [details]
use poll() instead of select() in rpmio.c
Comment 2 Jeff Johnson 2004-05-29 12:01:05 EDT
Hmmm, several problems with your patch, not just the memory leak.

Anyways, poll(2) now used instead of select(2) if available.

Patch checked in on HEAD and rpm-4_3 branch.

Note You need to log in before you can comment on or make changes to this bug.