Bug 124575 - apm attempts to create /dev/apm_bios, even when not needed
Summary: apm attempts to create /dev/apm_bios, even when not needed
Status: CLOSED WORKSFORME
Alias: None
Product: Fedora
Classification: Fedora
Component: apmd   
(Show other bugs)
Version: 2
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-05-27 16:57 UTC by Patrick Caldon
Modified: 2014-03-17 02:45 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-06-28 21:21:00 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Patrick Caldon 2004-05-27 16:57:15 UTC
Description of problem:

As a user, 'apm -s' results in failure.  looking at the code and
strace, it appears that apm tries to create /dev/apm_bios even if it
already exists, wich fails unless you're root.

Version-Release number of selected component (if applicable):

apmd-3.0.2-22

How reproducible:


Steps to Reproduce:
1. log in as user
2. type "apm -s"
3.
  
Actual results:

[mandy@localhost mandy]$ apm -s
apm: Operation not permitted
[mandy@localhost mandy]$

Expected results:

Machine suspended.

Additional info:

Comment 1 Alan Cox 2004-06-19 01:41:23 UTC
Works for me. 

It should be setting /dev/apm_bios to the most recent console or X
login. The idea is that the console users can suspend but not remote
users.


Comment 2 Bill Nottingham 2004-06-28 21:21:00 UTC
It does appear to be in console.perms correctly.


Note You need to log in before you can comment on or make changes to this bug.