Bug 124579 - ACPI: boot hang after a Plug & Play unless acpi=off - Dell OptiPlex GX110
Summary: ACPI: boot hang after a Plug & Play unless acpi=off - Dell OptiPlex GX110
Status: CLOSED NEXTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel   
(Show other bugs)
Version: 2
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Dave Jones
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-05-27 18:15 UTC by Alexander Tetervak
Modified: 2015-01-04 22:06 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-04-16 05:44:10 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
logs on a serial console from failed boots (20.00 KB, application/x-tar)
2004-05-29 08:01 UTC, Alexander Tetervak
no flags Details

Description Alexander Tetervak 2004-05-27 18:15:37 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4.2)
Gecko/20040308

Description of problem:
I have tried to install Fedora Core 2 on Dell OptiPlex GX110 (P3
700MHz). The installs hangs after a Plug & Play message it looks to me
when the kernel loads from CD. The same computer was used to install
run RedHat 9.0 and RedHat 7.3 without any   problems before. It is the
original Dell system with an extra 128M (total 256M) memory chip plus
an extra "tulip.o" network card. I have  sucessfully installed FC2 on
two other computers from the same CD set, so that CDs are good. I also
tried to boot from a hardrive with already installed FC2 on the
computer (I assumed that, ok, probably some modules would fail to
load) but the computers hangs after kernel decompression on kernel
loading.
It looks like some hardware support that was traditional for RedHat 
compiles of kernels is not included in the release. This happened to
be deadly critical for the "Dell OptiPlex GX110"   

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Install from FC2 with default or text options
I could not aviod the problem
    

Actual Results:  kernel hangs

Expected Results:  install to continue

Additional info:

Comment 1 Dave Jones 2004-05-27 18:34:18 UTC
can you get the exact message where it hangs ?

Does booting with acpi=off help ?


Comment 2 Alexander Tetervak 2004-05-27 21:50:47 UTC
The Last messages before the system hanged were:
PCI: Probing PCI Hardware (bus 00)
Transparent bridge - 0000:00:1e.0
ACPI: Interupt Link [LNKA](IRQs 3 4 5 6 7 8 *9 10 11 12 13 14 15)
ACPI: Interupt Link [LNKB](IRQs 3 4 5 6 7 8 9 *10 11 12 13 14 15)
ACPI: Interupt Link [LNKC](IRQs 3 4 *5 6 7 8 9 10 11 12 13 14 15)
ACPI: Interupt Link [LNKC](IRQs 3 4 5 6 7 8 9 10 *11 12 13 14 15)
Linux Plug and Play Support v0.97 (c) Adam Belay
no more messages, it is frozen

The suggested above install boot option
boot: linux acpi=off
resolved the install issue for me, the installer automatically
propagated acpi=off to GRUB setting to be used each time.
Thank you very much ;^)

Comment 3 Len Brown 2004-05-28 15:26:47 UTC
Please verify that the system is running the latest BIOS. 
 
Does it boot if you replace "acpi=off" with "pci=noacpi"? 
If so, can you attach the complete dmesg? 
 
Any chance we can boot with "debug" and w/o any acpi cmdline options 
and capture a serial console log? 
 

Comment 4 Alexander Tetervak 2004-05-29 08:01:42 UTC
Created attachment 100692 [details]
logs on a serial console from failed boots

Comment 5 Alexander Tetervak 2004-05-29 08:10:21 UTC
I run the latest "BIOS Version A09" from the www.dell.com
The option "pci=noacpi" does not help, boot hangs at the same spot.
I captured through a serial terminal failed boot messages with "debug"
(no any acpi options) and "debug pci=noacpi". I also included "dmesg"
file from a healthy boot with the "acpi=off" option. The stuff is in
"boot_logs.tar" attachment. 

Comment 6 shaohua li 2004-05-31 00:52:53 UTC
Could you please try the patch in http://bugme.osdl.org/show_bug.cgi?
id=2641. It resolves IO port reservation problem. Thanks.

Comment 7 Len Brown 2004-06-04 04:56:15 UTC
If the BIOS has any options to enable/disable PlugN'Plan support, 
please disable it. 

Comment 8 Dave Jones 2005-04-16 05:44:10 UTC
Fedora Core 2 has now reached end of life, and no further updates will be
provided by Red Hat.  The Fedora legacy project will be producing further kernel
updates for security problems only.

If this bug has not been fixed in the latest Fedora Core 2 update kernel, please
try to reproduce it under Fedora Core 3, and reopen if necessary, changing the
product version accordingly.

Thank you.



Note You need to log in before you can comment on or make changes to this bug.