This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 124585 - No ACPI suspend on "Lid" event
No ACPI suspend on "Lid" event
Status: CLOSED DUPLICATE of bug 81142
Product: Fedora
Classification: Fedora
Component: acpid (Show other bugs)
2
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-05-27 14:41 EDT by P Rauser
Modified: 2014-03-16 22:45 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:03:50 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description P Rauser 2004-05-27 14:41:50 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040510

Description of problem:
Fedora Core 2 clean install on IBM Thinkpad T40.  SELinux enabled in
"enforcing" mode, but problem reproduces itself after "setenforce 0"
from su.  acpid is installed and running.

Closing T40 laptop lid does not place system into suspend, nor does
opening the lid resume the system after it has been placed into
suspend via echo 3 > /proc/acpi/sleep.

I have created the following files mode 755, under both /etc/acpi and
/etc/acpid, but the problem persists:

# /etc/acpi/events/lid
event=button/lid
action=/etc/acpi/actions/lid.sh

-- and --

# /etc/acpi/actions/lid.sh
#!/bin/sh
echo 3 > /proc/acpi/sleep



Version-Release number of selected component (if applicable):
kernel-2.6.5-1.358, SELinux enabled

How reproducible:
Always

Steps to Reproduce:
1.  Close lid with or without APCI lid event 
2.  System does not suspend.
3.  Issue echo 3 > /proc/acpi/sleep.
4.  System suspends.
5.  Open or close of system lid has no effect; power button
successfully brings system out of suspend.    

Expected Results:  "Lid" event effects a suspend/resume.

Additional info:
Comment 1 Mike McLean 2004-06-21 17:57:22 EDT
reassigning to acpid
Comment 2 Bill Nottingham 2004-07-08 15:15:22 EDT

*** This bug has been marked as a duplicate of 81142 ***
Comment 3 Red Hat Bugzilla 2006-02-21 14:03:50 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.