Bug 124587 - reiserfs driver missing from standard kernel
reiserfs driver missing from standard kernel
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: kernel (Show other bugs)
3.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Burke
Brian Brock
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-05-27 15:33 EDT by Graham Leggett
Modified: 2007-11-30 17:07 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-06-02 17:26:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Graham Leggett 2004-05-27 15:33:29 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7b)
Gecko/20040514

Description of problem:
The reiserfs kernel modules are missing for the kernel.

This has caused problems with a machine that was upgraded from RH9
(which supported resierfs) to RHEL3 (which does not), which when
rebooted suddenly could not mount any of its filesystems. This machine
is in a managed hosting environment, and cannot be reinstalled from
scratch. Compiling a custom kernel is a very high maintenance
workaround, and is not acceptable as a long term solution.

In other words, please put it back :)


Version-Release number of selected component (if applicable):
kernel-2.4.21-15.EL

How reproducible:
Always

Steps to Reproduce:
xxx

Additional info:
Comment 2 Tim Burke 2004-06-02 17:26:19 EDT
We do not support reiserfs.  The reason for this position is that in
order for us to be able to responsibly support reiser, we would need
to fully staff up with the requisite expertiese.  Then we would have
to go through a comprehensive testing regiment, code review and
subsequent fixes as necessary to feel that it is confidently
enterprise ready.

Due to finite amount of time and developer/testing resources we are
not intending to deliver reiserfs on RHEL.
Comment 3 Graham Leggett 2004-06-02 17:31:51 EDT
...and the cost of that support is therefore passed directlly onto the
end user, who is now faced with the following options:

- Compile a custom kernel every time RH releases a new kernel release.
- Reinstall a machine that is on the exact opposite side of the world
from us, remotely.
- Choose another distro in future.
Comment 4 Rik van Riel 2004-06-02 22:02:11 EDT
The reiserfs module is present in the kernel-unsupported RPM.

This means that the module is available for your use and it almost
certainly works. However, it just doesn't go through the rigorous QA
process ext3 goes through and isn't supported by our support organisation.

OTOH, if there is a bug and a readily available fix (and a user
bringing both to our attention), said fix will probably be available
in a next update.

In short, no need to recompile your kernel.

Note You need to log in before you can comment on or make changes to this bug.