Bug 1245893 - size limit race condition: a processed problem was removed by another abrtd handler
Summary: size limit race condition: a processed problem was removed by another abrtd h...
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: abrt
Version: 6.6
Hardware: x86_64
OS: Linux
medium
medium
Target Milestone: rc
: ---
Assignee: Jakub Filak
QA Contact: Martin Kyral
Petr Bokoc
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: 1172231 1254457
TreeView+ depends on / blocked
 
Reported: 2015-07-23 05:38 UTC by jigar
Modified: 2017-05-22 11:57 UTC (History)
6 users (show)

(edit)
Fixed a race condition when processing of detected problems in *abrtd*

This update fixes a race condition in the *abrtd* service which was causing a loss of detected problem data, filling system logs with repeated error messages, and causing *abrt* core dumper processes to hang, which in turn prevented dumped programs from being restarted.
Clone Of:
: 1369433 (view as bug list)
(edit)
Last Closed: 2016-05-11 00:37:56 UTC


Attachments (Terms of Use)
Patch 1/2: testsuite: add concurrent processing test for abrtd (10.80 KB, patch)
2016-02-18 10:11 UTC, Jakub Filak
no flags Details | Diff
Patch 2/2: avoid race conditions in abrtd (6.69 KB, patch)
2016-02-18 10:11 UTC, Jakub Filak
no flags Details | Diff


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:0920 normal SHIPPED_LIVE abrt bug fix and enhancement update 2016-05-10 22:53:00 UTC

Description jigar 2015-07-23 05:38:08 UTC
Description of problem: Abrt error : '/var/spool/abrt/ccpp-2015-07-14-12:19:05-12547' is not a problem directory  . This message can be seen in /var/log/messages.

How reproducible:Sometimes


Steps to Reproduce:
The following error messages are seen in /var/log/messages:
ul 16 16:37:46 smf abrtd: '/var/spool/abrt/ccpp-2015-07-14-12:19:05-12547' is not a problem directory
Jul 16 16:37:47 smf abrtd: '/var/spool/abrt/ccpp-2015-07-14-12:19:05-12547' is not a problem directory
Jul 16 16:38:22 smf abrtd: '/var/spool/abrt/ccpp-2015-07-14-12:19:05-12547' is not a problem directory
Jul 16 16:38:23 smf abrtd: '/var/spool/abrt/ccpp-2015-07-14-12:19:05-12547' is not a problem directory
Jul 16 16:38:23 smf abrtd: New problem directory /var/spool/abrt/pyhook-2015-07-16-16:37:08-19857, processing
Jul 16 16:38:23 smf abrtd: Sending an email...
Jul 16 16:38:23 smf abrtd: Email was sent to: root@localhost

Actual results:
Abrt is reporting error messages.

Expected results:
Abrt should capture ccpp-* directory on crash.

Additional info:
Bug 847291 seems like a duplicate but was already fixed in abrt-2.0.8-6.el6.x86_64, libreport-2.0.9-5.el6.x86_64

Comment 5 Jakub Filak 2016-02-18 10:11:13 UTC
Created attachment 1128174 [details]
Patch 1/2: testsuite: add concurrent processing test for abrtd

Comment 6 Jakub Filak 2016-02-18 10:11:18 UTC
Created attachment 1128175 [details]
Patch 2/2: avoid race conditions in abrtd

Comment 10 errata-xmlrpc 2016-05-11 00:37:56 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-0920.html

Comment 11 Maël Lavault 2017-05-22 11:57:46 UTC
I have plenty of those message on every boot. As a result problems happening on boot are not reported, which is a shame since I have quite a few.


Note You need to log in before you can comment on or make changes to this bug.