Bug 1245957 - [WHQL][viostor][data-plane]it could not generate dump file on WIN2008-32/64 via WLK while running Crash Dump job
Summary: [WHQL][viostor][data-plane]it could not generate dump file on WIN2008-32/64 ...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: virtio-win
Version: 7.3
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: rc
: ---
Assignee: Vadim Rozenfeld
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-07-23 08:30 UTC by Min Deng
Modified: 2016-11-04 08:47 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
NO_DOCS
Clone Of:
Environment:
Last Closed: 2016-11-04 08:47:49 UTC
Target Upstream Version:


Attachments (Terms of Use)
Logs (2.57 MB, application/vnd.ms-cab-compressed)
2015-07-23 08:32 UTC, Min Deng
no flags Details
screenshot (20.08 KB, image/png)
2015-07-23 08:32 UTC, Min Deng
no flags Details
screenshot for BSOD hang at 0% (22.40 KB, image/png)
2015-10-20 05:53 UTC, Yu Wang
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:2609 normal SHIPPED_LIVE virtio-win bug fix and enhancement update 2016-11-03 15:27:12 UTC

Description Min Deng 2015-07-23 08:30:59 UTC
Description of problem:
It could  generate dump file on WIN2008-32/64 via WLK while running Crash Dump job

Version-Release number of selected component (if applicable):
kernel-3.10.0-297.el7.x86_64
qemu-kvm-rhev-2.3.0-12.el7.x86_64
virtio-win-prewhql-01-106

How reproducible:
4 times

Steps to Reproduce:
1.boot up guest with the following cli
  /usr/libexec/qemu-kvm -name 106BLK2008325VY -enable-kvm -m 4G -smp 4 -uuid 7ad2e9a0-814b-4591-a9f2-6dc565aaf328 -nodefconfig -nodefaults -cpu Nehalem,+fsgsbase -chardev socket,id=charmonitor,path=/tmp/106BLK2008325VY,server,nowait -mon chardev=charmonitor,id=monitor,mode=control -rtc base=localtime,driftfix=slew -boot order=cd,menu=on -device piix3-usb-uhci,id=usb,bus=pci.0,addr=0x1.0x2 -object iothread,id=thread0 -drive file=106BLK2008325VY,if=none,id=drive-ide0-0-0,format=raw,cache=none -device virtio-blk-pci,iothread=thread0,scsi=off,drive=drive-ide0-0-0,id=virtio-disk1 -drive file=en_windows_server_2008_datacenter_enterprise_standard_sp2_x86_dvd_342333.iso,if=none,media=cdrom,id=drive-ide0-1-0,readonly=on,format=raw -device ide-drive,bus=ide.1,unit=0,drive=drive-ide0-1-0,id=ide0-1-0 -drive file=106BLK2008325VY.vfd,if=none,id=drive-fdc0-0-0,format=raw,cache=none -global isa-fdc.driveA=drive-fdc0-0-0 -netdev tap,script=/etc/qemu-ifup,downscript=no,id=hostnet0 -device rtl8139,netdev=hostnet0,id=net0,mac=00:52:55:33:41:0c -chardev pty,id=charserial0 -device isa-serial,chardev=charserial0,id=isa_serial0 -device usb-tablet,id=input0 -vnc 0.0.0.0:1 -vga cirrus -drive file=106BLK2008325VY_test.raw,if=none,id=drive-virtio-disk0,format=raw,serial=mike_cao,cache=none -device virtio-blk-pci,iothread=thread0,scsi=off,bus=pci.0,addr=0x7,drive=drive-virtio-disk0,id=virtio-disk0 -monitor stdio

2.Submit the job 

3.At the stage of generating dump guest will hang.please see screen shot and logs

Actual results:
Dump file is generated while executing the job and finally it can pass without any issues.

Expected results:
The job could pass.

Additional info:
1.the job need to be executed on C:\(system disk)

2.how to run this job on the guest 
https://mojo.redhat.com/docs/DOC-1032622

3.After removing data-plane parameters the job could pass - work-round for us now

Comment 1 Min Deng 2015-07-23 08:32:34 UTC
Created attachment 1055229 [details]
Logs

Comment 2 Min Deng 2015-07-23 08:32:55 UTC
Created attachment 1055230 [details]
screenshot

Comment 7 Yu Wang 2015-10-20 05:53:10 UTC
Created attachment 1084602 [details]
screenshot for BSOD hang at 0%

Comment 9 Yu Wang 2016-01-06 06:16:53 UTC
Reproduced this issue on virtio-win-prewhql-106 version
Verified this issue on virtio-win-prewhql-112 version

Steps as comment#0:

Actual Results:
on virtio-win-prewhql-106 (un-fixed) version, the job failed w/ dataplane, hang at generating dump file.
on virtio-win-prewhql-112 fix version, job passed w/ dataplane, and generate dump file successfully.

Base on above, this issue has been fixed already.

Comment 10 Vadim Rozenfeld 2016-01-06 22:11:49 UTC
(In reply to wangyu from comment #9)
> Reproduced this issue on virtio-win-prewhql-106 version
> Verified this issue on virtio-win-prewhql-112 version
> 
> Steps as comment#0:
> 
> Actual Results:
> on virtio-win-prewhql-106 (un-fixed) version, the job failed w/ dataplane,
> hang at generating dump file.
> on virtio-win-prewhql-112 fix version, job passed w/ dataplane, and generate
> dump file successfully.
> 
> Base on above, this issue has been fixed already.

thanks.

Comment 11 Yu Wang 2016-05-27 03:07:03 UTC
According to comment#9, change status to "VERIFIED"

Additionally there is no "devel_ack" here. Please help to ack this bug.

Comment 14 errata-xmlrpc 2016-11-04 08:47:49 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2609.html


Note You need to log in before you can comment on or make changes to this bug.