Bug 1245966 - log files removexattr() can't find a specified key or value
Summary: log files removexattr() can't find a specified key or value
Keywords:
Status: CLOSED DUPLICATE of bug 1192832
Alias: None
Product: GlusterFS
Classification: Community
Component: protocol
Version: 3.5.4
Hardware: x86_64
OS: All
unspecified
unspecified
Target Milestone: ---
Assignee: bugs@gluster.org
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-07-23 08:43 UTC by Foudoulis Athanasios
Modified: 2015-09-24 06:58 UTC (History)
5 users (show)

Fixed In Version: glusterfs-3.5.4
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-09-24 06:56:13 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Foudoulis Athanasios 2015-07-23 08:43:36 UTC
Description of problem:
I have glusterFS with three bricks. Two of them on Ubuntu 12.04 and one on Ubuntu 14.04.

When I am trying to write files from the node running Ubuntu 14.04, the following errors/warnings occur (see logs below). However the files are successfully written and they are accessible from all the the nodes.

If I try to write the files directly to the folder used as brick, the error does not occur. It only occurs when writing thought the mount point. I am mounting the volume with
{THIS_NODE}:nova-gluster-vol /var/lib/nova/instances/      glusterfs       defaults,nobootwait

---> Log From Client ( /var/log/glusterfs/{VOLUME})
[2015-07-23 08:29:07.733023] E [iobuf.c:733:iobuf_unref] (-->/usr/lib/x86_64-linux-gnu/libglusterfs.so.0(call_resume+0x5cf) [0x7f040265510f] (-->/usr/lib/x86_64-linux-gnu/libglusterfs.so.0(default_readv_resume+0x14e) [0x7f040263bcbe] (-->/usr/lib/x86_64-linux-gnu/glusterfs/3.5.4/xlator/performance/quick-read.so(qr_readv+0x4e) [0x7f03fced721e]))) 0-iobuf: invalid argument: iobuf
[2015-07-23 08:29:07.733111] E [iobuf.c:839:iobref_unref] (-->/usr/lib/x86_64-linux-gnu/libglusterfs.so.0(call_resume+0x5cf) [0x7f040265510f] (-->/usr/lib/x86_64-linux-gnu/libglusterfs.so.0(default_readv_resume+0x14e) [0x7f040263bcbe] (-->/usr/lib/x86_64-linux-gnu/glusterfs/3.5.4/xlator/performance/quick-read.so(qr_readv+0x4e) [0x7f03fced721e]))) 0-iobuf: invalid argument: iobref
[2015-07-23 08:29:07.870181] W [fuse-bridge.c:1236:fuse_err_cbk] 0-glusterfs-fuse: 1779227: REMOVEXATTR() /_base/7f5ed776d0594ba0d82a16c8de31f43bc18f2ddf => -1 (No data available)
[2015-07-23 08:29:07.880319] W [fuse-bridge.c:1236:fuse_err_cbk] 0-glusterfs-fuse: 1779229: REMOVEXATTR() /_base/7f5ed776d0594ba0d82a16c8de31f43bc18f2ddf => -1 (No data available)
[2015-07-23 08:29:07.928179] W [fuse-bridge.c:1236:fuse_err_cbk] 0-glusterfs-fuse: 1779233: REMOVEXATTR() /_base/c527143e93073b5eaca89e2d8f356e043513aa73 => -1 (No data available)




---> Log From Server - node that brick resides ( /var/log/glusterfs/bricks/{VOLUME})
[2015-07-23 08:07:53.313335] E [marker.c:2573:marker_removexattr_cbk] 0-nova-gluster-vol-marker: No data available occurred while creating symlinks
[2015-07-23 08:11:37.497083] E [marker.c:2573:marker_removexattr_cbk] 0-nova-gluster-vol-marker: No data available occurred while creating symlinks
[2015-07-23 08:11:45.435734] E [marker.c:2573:marker_removexattr_cbk] 0-nova-gluster-vol-marker: No data available occurred while creating symlinks
[2015-07-23 08:11:46.722702] E [marker.c:2573:marker_removexattr_cbk] 0-nova-gluster-vol-marker: No data available occurred while creating symlinks
[2015-07-23 08:11:46.723805] E [marker.c:2573:marker_removexattr_cbk] 0-nova-gluster-vol-marker: No data available occurred while creating symlinks



Version-Release number of selected component (if applicable):
3.5.4 installed from ppa:gluster/glusterfs-3.5

How reproducible:


Steps to Reproduce:
1. Configure a glusterFS with 2 or more bricks
2. Write a file to volume, though mount point
3.

Actual results:


Expected results:


Additional info:

This bug or a similar one is fixed at 3.6.x according to https://bugzilla.redhat.com/show_bug.cgi?id=1188064. Is a backport to 3.5.X possible?

Comment 1 André Bauer 2015-09-02 07:53:54 UTC
Maybe this helps:

http://thedumontster.com/post/93787042025/kill-process-or-sacrifice-child

Comment 2 Anoop C S 2015-09-24 06:56:13 UTC

*** This bug has been marked as a duplicate of bug 1192832 ***


Note You need to log in before you can comment on or make changes to this bug.