Bug 1246082 - sharding - Populate the aggregated ia_size and ia_blocks before unwinding (f)setattr to upper layers
Summary: sharding - Populate the aggregated ia_size and ia_blocks before unwinding (f)...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: sharding
Version: mainline
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Krutika Dhananjay
QA Contact: bugs@gluster.org
URL:
Whiteboard:
Depends On:
Blocks: 1246988
TreeView+ depends on / blocked
 
Reported: 2015-07-23 12:36 UTC by Krutika Dhananjay
Modified: 2016-06-16 13:26 UTC (History)
1 user (show)

Fixed In Version: glusterfs-3.8rc2
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 1246988 (view as bug list)
Environment:
Last Closed: 2016-06-16 13:26:51 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Krutika Dhananjay 2015-07-23 12:36:09 UTC
Description of problem:
Sharding translator does not aggregate ia_size and ia_blocks in the cbks of (f)setattr. And fuse copies out poststat into the fuse output header before writing the response to /dev/fuse. This was causing issues with OS installation on vm images with sharded volumes.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. Create a dis-rep volume with sharding enabled and also all the options that need to be set which are documented at http://www.gluster.org/community/documentation/index.php/Libgfapi_with_qemu_libvirt.
2. Create a vm image on the volume.
3. Try to install (any) OS on this newly created image using virt-install CLI.
4. Open the UI on virt-manager and resume installation.
5. The application fails to recognise the virtio disk that is associated with the image.

Actual results:


Expected results:


Additional info:

Comment 1 Krutika Dhananjay 2015-07-24 06:39:44 UTC
http://review.gluster.org/#/c/11754/

Comment 2 Anand Avati 2015-07-27 06:06:32 UTC
COMMIT: http://review.gluster.org/11754 committed in master by Pranith Kumar Karampuri (pkarampu@redhat.com) 
------
commit fd296d90168002a475a9899a72a0dd1811f038ee
Author: Krutika Dhananjay <kdhananj@redhat.com>
Date:   Thu Jul 23 14:59:19 2015 +0530

    posix,shard: Fill in ia_size and ia_blocks before unwinding (f)setattr
    
    The shard xlator will request for size xattrs in its request and
    posix will perform xattr_fill of requested keys before unwinding
    (f)setattr.
    
    Change-Id: I4ec4779568be6f805724b875b1b4215787112e7f
    BUG: 1246082
    Signed-off-by: Krutika Dhananjay <kdhananj@redhat.com>
    Reviewed-on: http://review.gluster.org/11754
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Pranith Kumar Karampuri <pkarampu@redhat.com>
    Tested-by: NetBSD Build System <jenkins@build.gluster.org>

Comment 3 Nagaprasad Sathyanarayana 2015-10-25 15:13:43 UTC
Fix for this BZ is already present in a GlusterFS release. You can find clone of this BZ, fixed in a GlusterFS release and closed. Hence closing this mainline BZ as well.

Comment 4 Niels de Vos 2016-06-16 13:26:51 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.8.0, please open a new bug report.

glusterfs-3.8.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://blog.gluster.org/2016/06/glusterfs-3-8-released/
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user


Note You need to log in before you can comment on or make changes to this bug.