Bug 124611 - Reports "All of your loopback devices are in use." incorrectly
Summary: Reports "All of your loopback devices are in use." incorrectly
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: mkinitrd (Show other bugs)
(Show other bugs)
Version: 2
Hardware: i686 Linux
medium
medium
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-05-27 21:15 UTC by GeoffLeach
Modified: 2007-11-30 22:10 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-05-27 23:32:41 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description GeoffLeach 2004-05-27 21:15:36 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040510

Description of problem:
mkinitrd reports "All of your loopback devices are in use." when in
fact none are.  The error happens because the code LODEV=$(echo
findlodev | /sbin/nash --quiet) returns nothing. The problem is
repeatable for a given boot-up, and generally goes away when I reboot.
Kernel is stock 2.6.6, built locally; problem has occurred with prior
2.6.x versions.

Version-Release number of selected component (if applicable):
mkinitrd-3.5.22-1

How reproducible:
Always

Steps to Reproduce:
1.execute mkinitrd
2.observe failure
3.confirm echo findlodev | /sbin/nash --quiet
    

Actual Results:  %echo findlodev | /sbin/nash
(running in test mode).
Red Hat nash version 3.5.22 starting

%

Expected Results:  /dev/loop?

Additional info:

Comment 1 Jeremy Katz 2004-05-27 21:46:09 UTC
Do you have the loop module built/loaded?

Comment 2 GeoffLeach 2004-05-27 23:32:41 UTC
Yes, the loop module has been built, but now I remember, the last time
that this happened I figured out that the module had not loaded, and
modcomp fixed the problem


Note You need to log in before you can comment on or make changes to this bug.