Bug 1246119 - Wrong error message for too long name when we try to create location or organization
Summary: Wrong error message for too long name when we try to create location or organ...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Satellite
Classification: Red Hat
Component: Provisioning
Version: 6.1.0
Hardware: All
OS: Unspecified
unspecified
low vote
Target Milestone: Unspecified
Assignee: Shlomi Zadok
QA Contact: sthirugn@redhat.com
URL: http://projects.theforeman.org/issues...
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-07-23 13:29 UTC by Oleksandr Shtaier
Modified: 2019-09-26 18:06 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-07-27 08:54:06 UTC
Target Upstream Version:


Attachments (Terms of Use)
Screenshot with issue (46.14 KB, image/png)
2015-07-23 13:31 UTC, Oleksandr Shtaier
no flags Details


Links
System ID Priority Status Summary Last Updated
Foreman Issue Tracker 13378 None None None 2016-04-22 15:34:40 UTC
Red Hat Product Errata RHBA-2016:1500 normal SHIPPED_LIVE Red Hat Satellite 6.2 Base Libraries 2016-07-27 12:24:38 UTC

Description Oleksandr Shtaier 2015-07-23 13:29:46 UTC
Description of problem:
Probably we have defect in validation system for location and organization entities

Version-Release number of selected component (if applicable):
Beta

How reproducible:
Always


Steps to Reproduce:
1. Go to Organization or Location list
2. Push 'New Organization' or 'New Location' button
3. Input too long name (more than 256 symbols) for name field
4. Push 'Submit' button

Actual results:
'is too long (maximum is 246 characters) and is too long (maximum is 255 characters)' message is displayed

Expected results:
'is too long (maximum is 255 characters)' message is displayed

Additional info:

Comment 1 Oleksandr Shtaier 2015-07-23 13:31:46 UTC
Created attachment 1055386 [details]
Screenshot with issue

Comment 2 RHEL Program Management 2015-07-23 13:37:49 UTC
Since this issue was entered in Red Hat Bugzilla, the release flag has been
set to ? to ensure that it is properly evaluated for this release.

Comment 4 Brad Buckingham 2016-01-26 13:30:02 UTC
Created redmine issue http://projects.theforeman.org/issues/13378 from this bug

Comment 5 Bryan Kearney 2016-01-26 15:10:31 UTC
Upstream bug component is Provisioning

Comment 6 Bryan Kearney 2016-02-07 11:09:46 UTC
Upstream bug assigned to szadok@redhat.com

Comment 7 Bryan Kearney 2016-02-09 09:09:56 UTC
Moving to POST since upstream bug http://projects.theforeman.org/issues/13378 has been closed
-------------
Shlomi Zadok
Applied in changeset commit:b874d64ff64d23f0051c343b826669746b166211.

Comment 10 sthirugn@redhat.com 2016-04-07 20:48:42 UTC
Verified in satellite-6.2.0-6.2.beta.el7sat.noarch
Now the error message is shown as 'is too long (maximum is 255 characters)'

Comment 12 errata-xmlrpc 2016-07-27 08:54:06 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1500


Note You need to log in before you can comment on or make changes to this bug.