Bug 124613 - Reboot hangs at "turning off swap"
Reboot hangs at "turning off swap"
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
2
i586 Linux
medium Severity medium
: ---
: ---
Assigned To: Elliot Lee
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-05-27 17:26 EDT by Tako Schotanus
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-06-02 13:22:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Tako Schotanus 2004-05-27 17:26:26 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7b)
Gecko/20040421

Description of problem:
After upgrading from FC1 to FC2 rebooting the system will hang at the
point where it says "turning off swap". Trying to do "swapoff -a" will
hang forever as well.

Version-Release number of selected component (if applicable):
util-linux.2.12-18

How reproducible:
Always

Steps to Reproduce:
1. swapoff -a


Actual Results:  Nothing, it hangs

Expected Results:  Aything else but a hang. Not turning of swapping
while rebooting shouldn't be much of a problem I imagine so I could
just take it out but I'd rather fix the problem.

Additional info:

A similar problem seems to have been reported for SuSE but without any
infromation that I could use to fix the problem:
http://lists.suse.com/archive/suse-linux-e/2003-Nov/3666.html

The thread seems to suggest that having SCSI disks might be at the
heart of the problem and that is possible because at the moment of the
conversion from FC1 to FC2 the system contained an Adaptec SCSI card
with 2 CDROM drives. The card (and drives) have since been removed
from the system. Unfortunately I cannot test anymore if putting them
back would make everything work again.
Comment 1 Elliot Lee 2004-06-02 13:22:19 EDT
This would probably be the kernel.

If you can't reproduce the problem now, then there's no point in
working together on a fix. :\

Note You need to log in before you can comment on or make changes to this bug.