Bug 124616 - the line: include "/etc/named.custom" is not inserted into /etc/named.conf
the line: include "/etc/named.custom" is not inserted into /etc/named.conf
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: redhat-config-bind (Show other bugs)
3.0
noarch Linux
medium Severity medium
: ---
: ---
Assigned To: Jason Vas Dias
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-05-27 17:45 EDT by Roger Pena-Escobio
Modified: 2007-11-30 17:07 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-02 01:08:18 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Roger Pena-Escobio 2004-05-27 17:45:39 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4.2)
Gecko/20040329

Description of problem:
when the redhat-config-bind is used the first time, from a clean BIND
configuration, after you save the new configuration a new file
/etc/named.conf is created with the data saved but without a line like:
include "/etc/named.custom";

this line is mandatory because has importants definitions like
directory for zone files and the root zone file so, without this line
in named.conf, the new zone(s) created are _not_ loaded when the
server start.



Version-Release number of selected component (if applicable):
2.0.0-14

How reproducible:
Always

Steps to Reproduce:
1. backup the file /etc/named.conf and erase it
2. open the redhat-config-bind and create a new zone
3. save the new zone

    

Actual Results:  a new /etc/named.conf is create with the information
of the new zone created but without the link with the
/etc/named.custom file (the include directive)

Expected Results:  the information that the file already has plus the
include directive to load the named.custom file

Additional info:
Comment 1 Daniel Walsh 2004-06-23 16:10:52 EDT
Fixed in system-config-bind-2.0.2-9
Comment 3 Jay Turner 2004-09-02 01:08:18 EDT
An errata has been issued which should help the problem 
described in this bug report. This report is therefore being 
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files, 
please follow the link below. You may reopen this bug report 
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2004-364.html

Note You need to log in before you can comment on or make changes to this bug.