Bug 1246165 - verify_db.pl doesn't verify DB specified by -a option.
Summary: verify_db.pl doesn't verify DB specified by -a option.
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: 389-ds-base
Version: 6.0
Hardware: Unspecified
OS: Unspecified
low
low
Target Milestone: rc
: ---
Assignee: Noriko Hosoi
QA Contact: Viktor Ashirov
Petr Bokoc
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-07-23 15:07 UTC by Noriko Hosoi
Modified: 2020-09-13 21:27 UTC (History)
6 users (show)

Fixed In Version: 389-ds-base-1.2.11.15-67.el6
Doc Type: Bug Fix
Doc Text:
Cause: A command line utility verify-db.pl takes "-a Database Directory" to specify the path to the database. But even if it is given, the option was ignored and the path defined in the configuration was used. Fix: Now the bug was fixed and the given path to the database is used by verify-db.pl.
Clone Of:
Environment:
Last Closed: 2016-05-10 19:20:06 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github 389ds 389-ds-base issues 1546 0 None None None 2020-09-13 21:27:21 UTC
Red Hat Product Errata RHBA-2016:0737 0 normal SHIPPED_LIVE 389-ds-base bug fix and enhancement update 2016-05-10 22:29:13 UTC

Description Noriko Hosoi 2015-07-23 15:07:16 UTC
Description of problem:

verify-db.pl has option '-a 'which can specify path to DB.

https://access.redhat.com/documentation/en-US/Red_Hat_Directory_Server/9.0/html/Configuration_Command_and_File_Reference/Perl_Scripts.html#verify-db.pl

But if verify-db.pl run with -a option, it does not verify DB files under DB directory which is specified by option '-a',  but it alreays verify instance DB instead.


Steps to Reproduce:

1. take backup by db2bak
2. run DB verify against backup DB with -a option

e.g.
./verify-db.pl -a /var/lib/dirsrv/slapd-test/bak/test-2015_07_06_16_32_07

Actual results:

DB files unser instance's DB directory always get verified. 

Expected results:

DB files under DB directory specified -a option is verified.

Additional info:

Easy workaround:

N/A

Comment 3 Simon Pichugin 2015-12-03 16:02:43 UTC
Tested build: 389-ds-base-1.2.11.15-69.el6.x86_64

[root@test-machine test]# /usr/lib64/dirsrv/slapd-test-machine/db2bak.pl  -v -D "cn=directory manager" -w Secret123
Back up directory: /var/lib/dirsrv/slapd-test-machine/bak/test-machine-2015_12_3_10_57_48
ldap_initialize( ldap://test-machine.redhat.com:389 )
add objectclass:
        top
        extensibleObject
add cn:
        backup_2015_12_3_10_57_48
add nsArchiveDir:
        /var/lib/dirsrv/slapd-test-machine/bak/test-machine-2015_12_3_10_57_48
add nsDatabaseType:
        ldbm database
adding new entry "cn=backup_2015_12_3_10_57_48, cn=backup, cn=tasks, cn=config"
modify complete

[root@test-machine test]# /usr/lib64/dirsrv/slapd-test-machine/verify-db.pl -a /var/lib/dirsrv/slapd-test-machine/bak/test-machine-2015_12_3_10_57_48
*****************************************************************
verify-db: This tool should only be run if recovery start fails
and the server is down.  If you run this tool while the server is
running, you may get false reports of corrupted files or other
false errors.
*****************************************************************
Verify log files in /var/lib/dirsrv/slapd-test-machine/bak/test-machine-2015_12_3_10_57_48 ... Good
Verify db files ... Good

Marking as VERIFIED.

Comment 5 errata-xmlrpc 2016-05-10 19:20:06 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-0737.html


Note You need to log in before you can comment on or make changes to this bug.