Bug 1246229 - tier_lookup_heal.t contains incorrect file_on_fast_tier function
Summary: tier_lookup_heal.t contains incorrect file_on_fast_tier function
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: tiering
Version: mainline
Hardware: x86_64
OS: Unspecified
medium
medium
Target Milestone: ---
Assignee: Dan Lambright
QA Contact: bugs@gluster.org
URL:
Whiteboard:
Depends On:
Blocks: 1260923
TreeView+ depends on / blocked
 
Reported: 2015-07-23 18:31 UTC by Pan Ousley
Modified: 2016-06-16 13:26 UTC (History)
4 users (show)

Fixed In Version: glusterfs-3.8rc2
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-06-16 13:26:51 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Pan Ousley 2015-07-23 18:31:50 UTC
Tiering test script tier_lookup_heal.t contains old file_on_fast_tier function which incorrectly tests md5sums. Needs to be updated to contain improved function found in tier.t.

Comment 1 Anand Avati 2015-07-29 11:00:56 UTC
REVIEW: http://review.gluster.org/11792 (tests/tier: mark tiering related spurious failures as bad test) posted (#1) for review on master by mohammed rafi  kc (rkavunga@redhat.com)

Comment 2 Anand Avati 2015-07-29 19:17:23 UTC
REVIEW: http://review.gluster.org/11792 (tests/tier: mark tiering related spurious failures as bad test) posted (#2) for review on master by Dan Lambright (dlambrig@redhat.com)

Comment 3 Anand Avati 2015-07-29 19:18:04 UTC
COMMIT: http://review.gluster.org/11792 committed in master by Dan Lambright (dlambrig@redhat.com) 
------
commit 3bd335602be27bccad597a9156ecf80344bef88d
Author: Mohammed Rafi KC <rkavunga@redhat.com>
Date:   Wed Jul 29 16:24:37 2015 +0530

    tests/tier: mark tiering related spurious failures as bad test
    
    Change-Id: I808845e55103821eb5eda4c0650dc55facad01e2
    BUG: 1246229
    Signed-off-by: Mohammed Rafi KC <rkavunga@redhat.com>
    Reviewed-on: http://review.gluster.org/11792
    Reviewed-by: Dan Lambright <dlambrig@redhat.com>
    Tested-by: Dan Lambright <dlambrig@redhat.com>

Comment 6 Niels de Vos 2016-06-16 13:26:51 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.8.0, please open a new bug report.

glusterfs-3.8.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://blog.gluster.org/2016/06/glusterfs-3-8-released/
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user


Note You need to log in before you can comment on or make changes to this bug.