Bug 1246262 - sync plan dates saved incorrectly if I dont use the calendar widget
Summary: sync plan dates saved incorrectly if I dont use the calendar widget
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Content Management
Version: 6.1.0
Hardware: Unspecified
OS: Unspecified
unspecified
medium vote
Target Milestone: Unspecified
Assignee: Mike McCune
QA Contact: Corey Welton
URL: http://projects.theforeman.org/issues...
Whiteboard: Verified in Upstream
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-07-23 20:09 UTC by sthirugn@redhat.com
Modified: 2019-09-25 20:50 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-07-27 09:16:47 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:1501 normal SHIPPED_LIVE Red Hat Satellite 6.2 Capsule and Server 2016-07-27 12:28:58 UTC
Foreman Issue Tracker 11295 None None None 2016-04-22 16:38:51 UTC

Description sthirugn@redhat.com 2015-07-23 20:09:08 UTC
Description of problem:
sync plan dates saved incorrectly if I dont use the calendar widget

Version-Release number of selected component (if applicable):
Sat 6.1 GA Snap 14

How reproducible:
Always

Steps to Reproduce:
1. Navigate to Content -> Sync Plans
2. Click 'New Sync Plan'
3. Enter name=syncplan1, description=test sync plan, Interval=hourly
4. Enter a future date example in YYYY-MM-DD format: 2015-10-01 (type this text in the text box and do not select from the calendar widget)
5. Leave Start Time with default (current time)

Actual results:
Sync plan is created with start date of 2015-09-30 (One day less than what I entered)

Expected results:
Sync plan should be created with a requested start date and not one day prior.

Additional info:
This same date works fine when I select the date from the calendar widget.  This fails in QE automation for this same reason.

Comment 2 Chris Peters 2015-08-05 13:03:37 UTC
Created redmine issue http://projects.theforeman.org/issues/11295 from this bug

Comment 4 Tazim Kolhar 2015-11-17 08:58:26 UTC
VERIFIED:
# rpm -qa | grep foreman
dell-pem600-01.rhts.eng.bos.redhat.com-foreman-proxy-client-1.0-1.noarch
foreman-release-1.11.0-0.develop.201511111740gitb2a959e.el7.noarch
foreman-ovirt-1.11.0-0.develop.201511111740gitb2a959e.el7.noarch
foreman-libvirt-1.11.0-0.develop.201511111740gitb2a959e.el7.noarch
foreman-postgresql-1.11.0-0.develop.201511111740gitb2a959e.el7.noarch
foreman-selinux-1.11.0-0.develop.201510071426git6234447.el7.noarch
tfm-rubygem-foreman_hooks-0.3.9-1.el7.noarch
tfm-rubygem-hammer_cli_foreman_tasks-0.0.8-1.el7.noarch
tfm-rubygem-foreman_gutterball-0.0.1-3.el7.noarch
dell-pem600-01.rhts.eng.bos.redhat.com-foreman-client-1.0-1.noarch
dell-pem600-01.rhts.eng.bos.redhat.com-foreman-proxy-1.0-2.noarch
tfm-rubygem-foreman_discovery-4.1.2-1.fm1_11.el7.noarch
foreman-1.11.0-0.develop.201511111740gitb2a959e.el7.noarch
tfm-rubygem-foreman_docker-1.4.1-2.fm1_10.el7.noarch
tfm-rubygem-hammer_cli_foreman_bootdisk-0.1.3-3.el7.noarch
foreman-debug-1.11.0-0.develop.201511111740gitb2a959e.el7.noarch
foreman-proxy-1.11.0-0.develop.201511111339git7cbe47a.el7.noarch
foreman-compute-1.11.0-0.develop.201511111740gitb2a959e.el7.noarch
tfm-rubygem-hammer_cli_foreman_docker-0.0.3-4.el7.noarch
tfm-rubygem-foreman_bootdisk-6.0.0-2.fm1_10.el7.noarch
tfm-rubygem-hammer_cli_foreman-0.4.0-1.201511111650gitdda13df.el7.noarch
foreman-gce-1.11.0-0.develop.201511111740gitb2a959e.el7.noarch
foreman-release-scl-1-1.el7.x86_64
foreman-vmware-1.11.0-0.develop.201511111740gitb2a959e.el7.noarch
tfm-rubygem-foreman-tasks-0.7.6-1.fm1_10.el7.noarch

steps:
1. Navigate to Content -> Sync Plans
2. Click 'New Sync Plan'
3. Enter name=syncplan1, description=test sync plan, Interval=hourly
4. Enter a future date example in YYYY-MM-DD format: 2015-10-01 (type this text in the text box and do not select from the calendar widget)
5. Leave Start Time with default (current time)

Sync plan should be created with a requested start date.

Comment 9 errata-xmlrpc 2016-07-27 09:16:47 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1501


Note You need to log in before you can comment on or make changes to this bug.