Bug 124629 - Duplexing does not work on HP Deskjet 6122 (PCL 3) connected via USB.
Duplexing does not work on HP Deskjet 6122 (PCL 3) connected via USB.
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: system-config-printer (Show other bugs)
2
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-05-27 21:41 EDT by John Bunch
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-08-11 06:26:36 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Portion of /var/log/cups/error_log during the duplex test. (660 bytes, text/plain)
2004-05-27 21:49 EDT, John Bunch
no flags Details
Portion of /var/log/cups/error_log during the duplex test with duplex driver option on. (814 bytes, text/plain)
2004-05-28 12:02 EDT, John Bunch
no flags Details
Portion of /var/log/cups/error_log during the duplex test with duplex driver option on and LogLevel at debug2. (86.49 KB, text/plain)
2004-06-04 19:28 EDT, John Bunch
no flags Details
"class: PRINTER" section from /etc/sysconfig/hwconf. (228 bytes, text/plain)
2004-07-14 16:46 EDT, John Bunch
no flags Details
HP-DeskJet_6122.xml (2.47 KB, text/plain)
2004-07-21 11:07 EDT, Tim Waugh
no flags Details
printconf_conf.py (55.11 KB, text/plain)
2004-07-21 13:35 EDT, Tim Waugh
no flags Details
getusbprinterid.pl (603 bytes, text/plain)
2004-07-22 05:26 EDT, Tim Waugh
no flags Details
Output from ./getusbprinterid.pl /dev/usb/lp0 (203 bytes, text/plain)
2004-07-22 11:56 EDT, John Bunch
no flags Details
printconf_conf.py (55.14 KB, text/plain)
2004-07-26 08:25 EDT, Tim Waugh
no flags Details

  None (edit)
Description John Bunch 2004-05-27 21:41:39 EDT
Description of problem:  Selecting "Duplex test" from the "Printer
configuration" windows causes two separate sheets to come out with
writing only on one side, not a single sheet with writing on both sides.


Version-Release number of selected component (if applicable):
0.6.98-1

How reproducible:  Always.


Steps to Reproduce:
1.  Select System Tools > Print Manager.
2.  Select Printer > Properties.  Enter root password.
3.  Select the printer, which is an HP Deskjet 6122 (PCL 3) connected
via the USB port.
4.  Select Test > Duplex test.
  
Actual results:  Two pages come out, one with a large number "1", and
the second with a large number "2".


Expected results:  A single page should come out, with the numbers on
opposite sides.


Additional info:
Comment 1 John Bunch 2004-05-27 21:49:03 EDT
Created attachment 100650 [details]
Portion of /var/log/cups/error_log during the duplex test.

Although the last line says "Media tray empty!", there is plenty of paper in
the printer's only media tray, and it did print the job (but it used two sheets
instead of one).
Comment 2 Tim Waugh 2004-05-28 02:54:07 EDT
Do you have duplex enabled in the driver options for that printer?
Comment 3 John Bunch 2004-05-28 12:02:54 EDT
Created attachment 100670 [details]
Portion of /var/log/cups/error_log during the duplex test with duplex driver option on.

During the first test, "Double-Sided Printing" was set to "Printer Default." 
As noted previously, two pages were printed, but no duplexing occurred.

I changed the "Double-Sided Printing" setting to "On (Flip on Long Edge)" and
applied the change.  When I ran the duplex test for the second time, nothing
printed at all.  I have attached the portion of the log from this second duplex
test.  The "CUPS test page" would not print, either.  I changed the
"Double-Sided Printing" option back to "Printer Default", and then "CUPS test
page" prints fine.
Comment 4 Tim Waugh 2004-06-03 19:00:08 EDT
Could you please set LogLevel to debug2 (in /etc/cups/cupsd.conf) and
try again?  By the way, the 'Media tray empty' message is a
red-herring, and is not causing this problem.
Comment 5 John Bunch 2004-06-04 19:28:57 EDT
Created attachment 100887 [details]
Portion of /var/log/cups/error_log during the duplex test with duplex driver option on and LogLevel at debug2.

Sequence of events recorded in the attached log:

Booted Linux, set LogLevel to debug2, and rebooted.
17:54:09  Started "Printer configuration" tool.
17:55:19  Selected printer.
18:13:08  Set "Double-Sided Printing" to On (Flip on Long Edge).
18:15	  Action > Apply
18:16	  Test > Duplex Test (nothing printed).
Comment 6 Tim Waugh 2004-07-14 13:32:05 EDT
I think the problem is that we don't have autodetect information for
this printer.

Please attach the relevant 'class: PRINTER' section from
/etc/sysconfig/hwconf.  Thanks.
Comment 7 John Bunch 2004-07-14 16:46:26 EDT
Created attachment 101919 [details]
"class: PRINTER" section from /etc/sysconfig/hwconf.
Comment 8 Tim Waugh 2004-07-21 11:07:18 EDT
Created attachment 102107 [details]
HP-DeskJet_6122.xml

Please replace /usr/share/foomatic/db/source/printer/HP-DeskJet_6122.xml with
this attachment, then remove and re-add the print queue.  Does this help?
Comment 9 John Bunch 2004-07-21 12:07:49 EDT
Well, I tried it two ways, and here is what happened:
1.  I changed the driver setting to duplex (flip on long edge),
applied the change, then tried the duplex test from the menu.  Nothing
printed.
2.  I changed the driver setting back to printer default, applied the
changed, then tried the duplex test from the menu again.  I got two
separate pages of output, but each was printed single-sided.
Comment 10 Tim Waugh 2004-07-21 12:13:05 EDT
You must remove and re-add the queue.  Changing the existing queue is
not sufficient.  Please remove and then re-add the queue, and let me
know what behaviour you get.  The intention is that the correct
printer model is detected, rather than 'Generic PCL3.'
Comment 11 John Bunch 2004-07-21 12:35:09 EDT
Thank you.  I created it as a "DeskJet 6122," and it duplexes fine, as
long as the driver setting is set to duplexing mode (if the driver's
duplex setting is set to "off," it prints separate pages).  I think
that may have been the problem all along, since I originally created
the queue for a generic PCL 3 printer.  I apologize for my ignorance.
Comment 12 Tim Waugh 2004-07-21 12:40:22 EDT
When you added the printer did you have to tell the computer what
model the printer was, or did it work it out for itself?  The change
is intended to make the right thing happen without unnecessary user
action.

Did that work?
Comment 13 John Bunch 2004-07-21 12:56:42 EDT
No.  I just deleted and recreated the queue again, and took note of
what happened.  After selecting the USB device, it prompted me for the
printer type.  The combo box showed "Generic ...", and that is where I
originally selected PCL 3.  To select the HP DeskJet 6122 model, I had
to change the combo box to "HP", then scroll down through the long
list to find DeskJet 6122.
Comment 14 Tim Waugh 2004-07-21 13:35:08 EDT
Created attachment 102113 [details]
printconf_conf.py

Please replace /usr/share/printconf/util/printconf_conf.py with this
attachment.

Run system-config-printer from the command line and, when you go to add the
queue, there should be a message about the USB identification strings in the
terminal.  What does that say?
Comment 15 John Bunch 2004-07-21 20:38:16 EDT
I recreated the queue from the command line, and here is all the output:

[root@bunch util]# system-config-printer
/usr/bin/ptal-devid: Unable to open device "device"!
 
Syntax: /usr/bin/ptal-devid [<devname>] [-previous] [[<modifiers>]
<queries>]...Where <devname> may be one of:
Supported <modifiers> (for following <queries>):
        -previous    -- Gets previous string (must be first option)
        -short       -- Displays field values only
        -long        -- Displays leading field name through semicolon
Supported <queries>:
        -field <key> -- Queries specific field
        -mfg         -- Queries manufacturer fields
        -mdl         -- Queries model fields
        -cmd         -- Queries command set fields
        -sern        -- Queries serial number fields
 
Comment 16 Tim Waugh 2004-07-22 05:26:30 EDT
Created attachment 102134 [details]
getusbprinterid.pl

Please save this attachment as 'getusbprinterid.pl', and run (as root):

chmod a+x getusbprinterid.pl
./getusbprinterid.pl /dev/usb/lp0

What output does it give?
Comment 17 John Bunch 2004-07-22 11:56:04 EDT
Created attachment 102148 [details]
Output from ./getusbprinterid.pl /dev/usb/lp0
Comment 18 Tim Waugh 2004-07-22 12:09:02 EDT
Good, they're the strings I expected, and the ones that are in your
HP-DeskJet_6122.xml file.  But system-config-printer put you at
'Generic' when choosing the model?  How odd.
Comment 19 John Bunch 2004-07-22 12:36:48 EDT
I just tested system-config-printer again, and what you just wrote is
correct.
Comment 20 Tim Waugh 2004-07-26 08:25:59 EDT
Created attachment 102201 [details]
printconf_conf.py

Please try replacing /usr/share/printconf/util/printconf_conf.py with this
attachment, removing /usr/share/printconf/util/printconf_conf.pyc and
/usr/share/printconf/util/printconf_conf.pyo if they exist, and trying again.

Does that give a message like 'Trying to match USB ...'?
Comment 21 John Bunch 2004-08-02 20:00:42 EDT
I replaced printconf_conf.py with the attachment, then deleted
printconf_conf.pyo (printconf_conf.pyc did not exist, and still does
not).  I then deleted and recreated the queue, but nothing appears to
have changed.  It still does not recognize the printer, forcing me to
select it from the list.  I saw no message like "Trying to match USB
...", and I also searched the error log for "trying"
(case-insensitive), but found nothing.
Comment 22 Tim Waugh 2004-08-03 06:23:42 EDT
It won't be in the error_log but the terminal you ran
system-config-printer from.
Comment 23 John Bunch 2004-08-03 10:46:54 EDT
I recreated the queue again, this time using the
"system-config-printer" command, but absolutely no messages appeared
in the terminal window.
Comment 24 Tim Waugh 2004-08-05 11:39:57 EDT
Please try fetching this package:

http://cyberelk.net/tim/tmp/124629/

Install it with 'rpm -Fvh system-config-printer*0.6.107*.rpm'

Does that give better results?
Comment 25 John Bunch 2004-08-05 18:42:42 EDT
When I clicked on the link, I received the following error:

Forbidden
You don't have permission to access /tim/tmp/124629/ on this server.

Apache/1.3.26 Server at www.cyberelk.net Port 80
Comment 26 Tim Waugh 2004-08-06 04:46:12 EDT
Oops, sorry!  Please use this URL instead:

  http://cyberelk.net/tim/data/tmp/124629/
Comment 27 John Bunch 2004-08-06 18:00:18 EDT
Yes, that gave better results.  My printer was automatically detected,
so I did not have to select it from the list.  Furthermore, I enabled
the driver's duplexing option and then successfully ran a duplex test.

Thank you for keeping Linux up to par with this new printer of mine!
Comment 28 Tim Waugh 2004-08-11 06:26:36 EDT
Great.

Note You need to log in before you can comment on or make changes to this bug.