Bug 124630 - CMIPCI on board sound card Configed no sound
CMIPCI on board sound card Configed no sound
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
2
All Linux
medium Severity high
: ---
: ---
Assigned To: Dave Jones
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-05-27 21:43 EDT by oiaohm
Modified: 2015-01-04 17:06 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-04-16 00:27:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
lspci -vv for the CMI 8738 soundcard (685 bytes, text/plain)
2004-08-02 00:02 EDT, Rey Batioco
no flags Details

  None (edit)
Description oiaohm 2004-05-27 21:43:05 EDT
Description of problem:
Really simple no sound does not do a thing bar load driver into memory

Version-Release number of selected component (if applicable):


How reproducible:
100%

Steps to Reproduce:
1. Have CMIPCI motherboard/sound card
2. auto detect sound card
3. No test sound/No sound
  
Actual results:
No sound

Expected results:
Sound

Additional info:
The fix is really simple add the option line to the modules file.
options snd-cmipci id="first" mpu_port=0x300
The dam driver does not have any default setting give it no setting it
loads and does nothing more than what sending a sound file to a NULL will.

Also Please give a advanced button with the means of entering a manual
options line if required so that new users don't have to be manually
editing it in for other cards.

Basicly it is a verry annoying Opps as a lot of on board sound users
this driver.
Comment 1 Burkhard 2004-07-08 03:34:07 EDT
Fix did not work for me. But in my modprobe.conf the module was
spelled cmpci, as was the name of the old oss driver name. Changing
this line to
alias sound-slot-0 snd-cmipci
and the corresponding line in /etc/sysconfig/hwconf to
driver: snd-cmipci
worked for me.

Perhaps this mess had something to do with the upgrade process from
FC1 to FC2.A (redhat-magazine). I did not test the fix on a clean FC2
installation.
Comment 2 Bastien Nocera 2004-07-21 12:49:10 EDT
Burkhard:
If the /etc/modprobe.conf read "alias sound-slot-0 cmpci", and not
"alias sound-slot-0 snd-cmipci", that would a relic of your FC1
installation, you would have had to change that by hand.

oiaohm:
I'll reassign this bug to kudzu, which should be able to detect and
configure your card properly.
Is the card PCI or ISA? If it is ISA, could you attach the output of
isapnp to this issue? If it isn't, then the bug should be reassigned
to the kernel, as the users shouldn't have to do more than selecting
the driver for the card to work.
Comment 3 Bill Nottingham 2004-07-21 14:45:41 EDT
The bad rename on upgrade is fixed in current hwdata packages, FWIW.
Comment 4 oiaohm 2004-07-22 01:28:43 EDT
My problem is that I have had 2 different motherboards onboard that
are not mine both gave the same error ie I missed geting the file
while I was setting them up if I get a third attempt.  That is the
reson for that being missing.

Sorry Burkhard these were clean installs alias sound-slot-0 was right
with snd-cmipci problem was that the driver was not coming up with a
default as was mentioned alsa site ie options snd-cmipci id="first"
mpu_port=0x300 added to the modules file and is required.  And it is
also the reason why I ask for a way to add a option line in case of
strange errors so can simply over ride if needed.

Basicly my problem has nothing to do with Burkhards problem.
Comment 5 Rey Batioco 2004-07-31 07:24:16 EDT
I am experiencing the same issue on my fresh install of FC2 at home. 
I have a CMI8738 4 channel PCI soundcard.  This worked well in FC1.  I
tried adding the:

   options snd-cmipci id="first" mpu_port=0x300

and rebooting but still had no sound.  I will update this report once
I get the workaround or fix.
Comment 6 oiaohm 2004-08-01 05:10:41 EDT
I when over alsa-project.org again I guess either I stuffed up or the
onboards I was working with was strange note I had the model number
when I got the info this is a case I work on something forget to get
all the info and have a problem latter 2.

This line is the fix for the cmi8738 and Looks like most others is.
options snd-cmipci id="first" enable_midi="1"

I going to www.alsa-project.org when I have problems in this section
sorry about the mistack.  I the fault is right somewhere the notes
file got the patch mixed up.
Comment 7 Rey Batioco 2004-08-02 00:02:05 EDT
Created attachment 102347 [details]
lspci -vv for the CMI 8738 soundcard
Comment 8 Rey Batioco 2004-08-02 00:14:53 EDT
its okay oiaohm, i was able to find the workarounds for this issue:

METHOD 1:

1)  Login as root and open a terminal from system tools.  Issue the
following:

   alsactl store

2)  Edit the following file:

   /etc/asound.state

and change the following controls to false:

   "Exchange DAC" and "IEC958 In Monitor"

example:
        control.26 {
                comment.access 'read write'
                comment.type BOOLEAN
                iface MIXER
                name 'Exchange DAC'
                value false
        }
        control.32 {
                comment.access 'read write'
                comment.type BOOLEAN
                iface MIXER
                name 'IEC958 In Monitor'
                value false
        }

and then save and exit the file.

3)  Issue the following to apply the the new sound settings:

   alsactl restore
   
4)  Enjoy your sounds!!!

METHOD 2:

1)  Run the "Kmix" program from "Sound and Video".
2)  Check the "advanced" checkbox and it should show you a lot more
options.  
3)  Disable the following controls:

   "Exchange DAC" and "IEC958 In Monitor"

by clicking on the green buttons assigned to them.
4)  Enjoy your sounds.

NOTE:  I have attached the lspci -vv for the soundcard before this
comment.
Comment 9 Bill Nottingham 2004-08-02 15:36:58 EDT
If these are required by default, I'm curious why they're not set that
way in the driver.
Comment 10 oiaohm 2004-08-03 19:47:52 EDT
These below are not default setting

        control.26 {
                comment.access 'read write'
                comment.type BOOLEAN
                iface MIXER
                name 'Exchange DAC'
                value false
        }
        control.32 {
                comment.access 'read write'
                comment.type BOOLEAN
                iface MIXER
                name 'IEC958 In Monitor'
                value false
        }
These are partical card work arounds(most likey locked to brand and/or
model number).  This is a work around from the 03 March 2004.  I back
using this Number one if card is trouble ie a one with a problem this
will alown it to work or if the card works find.  From the notes on
alsa some card might also have chipset problems in the IEC958   

lso found why the mpu_port=0x300 it is the work around in a version of
Alsa ie mpu_port=0x300 equals enable_midi="1" option part
>For Alsa 1.0.0rc2: to enable the MIDI port on the MD-Mate, add the
>line
>
>   options snd-cmipci mpu_port=0x300
>
>to the file "/etc/modules.conf". The option "enable_midi" is no
>longer supported, as it seems.
This could be out of date
Comment 11 Dave Jones 2005-04-16 00:27:35 EDT
Fedora Core 2 has now reached end of life, and no further updates will be
provided by Red Hat.  The Fedora legacy project will be producing further kernel
updates for security problems only.

If this bug has not been fixed in the latest Fedora Core 2 update kernel, please
try to reproduce it under Fedora Core 3, and reopen if necessary, changing the
product version accordingly.

Thank you.

Note You need to log in before you can comment on or make changes to this bug.