Bug 124632 - Kudzu hangs on startup
Kudzu hangs on startup
Status: CLOSED DUPLICATE of bug 126342
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
2
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Dave Jones
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-05-27 21:49 EDT by Jean-Marc Valin
Modified: 2015-01-04 17:06 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-11-02 22:43:49 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Jean-Marc Valin 2004-05-27 21:49:59 EDT
Description of problem:
When removing the CDROM drive from my laptop, Fedora Core 2 wouldn't
boot because it was stuck in kudzu forever

Version-Release number of selected component (if applicable):


How reproducible:
As soon as hardware is changed

Steps to Reproduce:
1. Remove some hardware
2. Boot Fedora
3. Hang
  
Actual results:
Hang

Expected results:
No Hang

Additional info:
I have a Dell Latitude D600 laptop, I've never experienced that
problem with other distros before. Right now, I have kudzu removed
from rc5.d because otherwise it won't boot.
Comment 1 Bill Nottingham 2004-05-28 12:23:01 EDT
What happens if you strace it post-boot?
Comment 2 Jean-Marc Valin 2004-05-28 13:12:22 EDT
saw nothing in the /var/log/messages. Note that this happens with a
custom kernel (2.6.5-mm6) which otherwise (no kudzu) runs fine.
Comment 3 Bill Nottingham 2004-05-28 13:58:23 EDT
So, post-boot, it works?
Comment 4 Jean-Marc Valin 2004-05-28 15:58:11 EDT
Post-boot is also hangs. When I do a ps, the thing that seems to hang is:
/sbin/modprobe -q -r ohci1394
and the logs have:
ieee1394: Initialized config rom entry `ip1394'

Note that I do NOT have a firewire controller on this laptop.
Comment 5 Bill Nottingham 2004-05-28 17:16:06 EDT
This is a bug in the kernel firewire layer.
Comment 6 Jean-Marc Valin 2004-05-28 17:32:53 EDT
Note that I used exactly the same kernel (2.6.5-mm5) with FC1 with no
such problem.
Comment 7 Arjan van de Ven 2004-05-29 04:13:57 EDT
Ehhh FC2 has no firewire so how can it be a kernel firewire layer
problem ?
Comment 8 Jean-Marc Valin 2004-05-29 04:29:31 EDT
Dunno if that's relevent, but I think the problem only occurs with a
custom kernel, not the default FC2 kernel. Still annoying though.
Comment 9 Dave Jones 2004-11-02 22:43:49 EST

*** This bug has been marked as a duplicate of 126342 ***

Note You need to log in before you can comment on or make changes to this bug.