Bug 1246329 - umount.nfs -h/--help output typo with -f force unmount
Summary: umount.nfs -h/--help output typo with -f force unmount
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: nfs-utils
Version: 7.1
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Steve Dickson
QA Contact: Yongcheng Yang
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-07-24 03:13 UTC by Yongcheng Yang
Modified: 2016-11-04 05:00 UTC (History)
1 user (show)

Fixed In Version: nfs-utils-1.3.0-0.29.el7
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-11-04 05:00:12 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:2383 0 normal SHIPPED_LIVE nfs-utils bug fix and enhancement update 2016-11-03 13:53:02 UTC

Description Yongcheng Yang 2015-07-24 03:13:18 UTC
Description of problem:


Version-Release number of selected component (if applicable):
RHEL-7.1

How reproducible:
100%

Steps to Reproduce:
1. umount.nfs --help
(or umount.nfs -h)

Actual results:
[root@intel-s3e36-01 ~]# umount.nfs --help
usage: umount.nfs dir [-fvnrlh]
options:
	-f		force unmount
                ^^^^^^^^<<<<<<<<<<<<<< should remove the spare space
	-v	verbose
	-n	Do not update /etc/mtab
	-r	remount
	-l	lazy unmount
	-h	print this help


Expected results:
[root@intel-s3e36-01 ~]# umount.nfs --help
usage: umount.nfs dir [-fvnrlh]
options:
	-f	force unmount
	-v	verbose
	-n	Do not update /etc/mtab
	-r	remount
	-l	lazy unmount
	-h	print this help


Additional info:
[yyc@dhcp-12-138 nfs-utils]$ grep -A9 "umount_usage" utils/mount/utils.c
void umount_usage(void)
{
	printf(_("usage: %s dir [-fvnrlh]\n"), progname);
	printf(_("options:\n\t-f\t\tforce unmount\n"));
                                ^^^^<<<<<<<<<<<<<<<<<<<< should remove one '\t'
	printf(_("\t-v\tverbose\n"));
	printf(_("\t-n\tDo not update /etc/mtab\n"));
	printf(_("\t-r\tremount\n"));
	printf(_("\t-l\tlazy unmount\n"));
	printf(_("\t-h\tprint this help\n\n"));
}
[yyc@dhcp-12-138 nfs-utils]$

Comment 1 Steve Dickson 2016-06-07 20:17:35 UTC
commit a5f1e5797f465d326043eb9daa5f1ad3750d4c9d
Author: Steve Dickson <steved@redhat.com>
Date:   Tue Jun 7 16:07:27 2016 -0400

    umount: fixed typo in usage message
    
    Signed-off-by: Steve Dickson <steved@redhat.com>

Comment 3 Yongcheng Yang 2016-06-12 02:16:43 UTC
Verified with nfs-utils-1.3.0-0.29.el7

Move to VERIFIED and continue to run the automatic case.

[root@ibm-x3550m4-02 ~]# rpm -q nfs-utils
nfs-utils-1.3.0-0.28.el7.x86_64
[root@ibm-x3550m4-02 ~]# umount.nfs -h
usage: umount.nfs dir [-fvnrlh]
options:
	-f		force unmount
	-v	verbose
	-n	Do not update /etc/mtab
	-r	remount
	-l	lazy unmount
	-h	print this help

[root@ibm-x3550m4-02 ~]# 
[root@ibm-x3550m4-02 ~]# rpm -Uvh nfs-utils-1.3.0-0.29.el7.x86_64.rpm 
Preparing...                          ################################# [100%]
Updating / installing...
   1:nfs-utils-1:1.3.0-0.29.el7       ################################# [ 50%]
Cleaning up / removing...
   2:nfs-utils-1:1.3.0-0.28.el7       ################################# [100%]
[root@ibm-x3550m4-02 ~]# rpm -q nfs-utils
nfs-utils-1.3.0-0.29.el7.x86_64
[root@ibm-x3550m4-02 ~]# umount.nfs -h
usage: umount.nfs dir [-fvnrlh]
options:
	-f	force unmount
	-v	verbose
	-n	Do not update /etc/mtab
	-r	remount
	-l	lazy unmount
	-h	print this help

[root@ibm-x3550m4-02 ~]# umount.nfs --help
usage: umount.nfs dir [-fvnrlh]
options:
	-f	force unmount
	-v	verbose
	-n	Do not update /etc/mtab
	-r	remount
	-l	lazy unmount
	-h	print this help

[root@ibm-x3550m4-02 ~]#

Comment 5 errata-xmlrpc 2016-11-04 05:00:12 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2383.html


Note You need to log in before you can comment on or make changes to this bug.