Bug 124636 - FAM eats all CPU available
FAM eats all CPU available
Status: CLOSED DUPLICATE of bug 124361
Product: Fedora
Classification: Fedora
Component: fam (Show other bugs)
2
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Daniel Veillard
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-05-27 22:04 EDT by Jean-Marc Valin
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:03:51 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jean-Marc Valin 2004-05-27 22:04:26 EDT
Description of problem:
I'm having problems with fam on my machine (Fedora Core 2). When
running one of my programs and redirecting stdout to a file, fam ends
up eating all the CPU. During a normal run, my program takes 10
seconds of CPU while sneding 6.7 MB of data to stdout (which ends up
in a file). In the meantime, fam ended up using 2 minutes(!!) of CPU:
12x more than the program it's monitoring. The file I'm writing is on
a local filesystem and I have no filemanager open. Also, I've been
able to see that if I remove the prints, fam no longer eats CPU. This
has been confirmed by someone on the FAM list.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Dell D600 laptop with Pentium-M 1.6 GHz CPU, 1 GB RAM
Comment 1 Michael Schwendt 2004-07-12 14:57:11 EDT

*** This bug has been marked as a duplicate of 124361 ***
Comment 2 Red Hat Bugzilla 2006-02-21 14:03:51 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.