Bug 1246423 - openshift plugin for OSE v3
Summary: openshift plugin for OSE v3
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: sos   
(Show other bugs)
Version: 7.1
Hardware: All
OS: Linux
medium
medium
Target Milestone: rc
: ---
Assignee: Pavel Moravec
QA Contact: Miroslav Hradílek
Robert Krátký
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: 1203710 1295396 1298112 1313485
TreeView+ depends on / blocked
 
Reported: 2015-07-24 09:45 UTC by Josep 'Pep' Turro Mauri
Modified: 2016-11-04 04:53 UTC (History)
13 users (show)

Fixed In Version: sos-3.3-1.el7
Doc Type: Enhancement
Doc Text:
*Origin* plug-in added to the _sos_ package The *origin* plug-in has been added to the _sos_ package. The plug-in collects information about *OpenShift Origin* and related products, such as *Atomic Platform* or *OpenShift Enterprise 3* and higher. This allows users to gather information about *OpenShift Origin* deployments.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-11-04 04:53:52 UTC
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:2380 normal SHIPPED_LIVE sos bug fix and enhancement update 2016-11-03 13:52:35 UTC
Red Hat Knowledge Base (Solution) 1542293 None None None Never

Description Josep 'Pep' Turro Mauri 2015-07-24 09:45:53 UTC
Description of problem:
Current versions of the openshift plugin in sos cover version 2.x of OpenShift Enterprise (upstream Origin M4). However, OSE 3 (origin M5) is a very different product and the existing plugin does not collect any relevant information about it.

A new sos plugin is needed for OpenShift Enterprise V3 / Origin latest.

Version-Release number of selected component (if applicable):
sos-3.2-15.el7_1.5

Additional info:

Note that OSE 2.x only runs on RHEL6 and OSE 3.x only runs on RHEL7+. Therefore this request is specific to sos on RHEL7 and doesn't need to be backported to EL6.

Comment 1 Josep 'Pep' Turro Mauri 2015-07-24 09:54:25 UTC
Created https://github.com/sosreport/sos/issues/612 upstream for suggestions on how to fix this.

Comment 2 Pavel Moravec 2015-07-27 15:36:24 UTC
(In reply to Josep 'Pep' Turro Mauri from comment #1)
> Created https://github.com/sosreport/sos/issues/612 upstream for suggestions
> on how to fix this.

Kicked off discussion there.

Comment 10 Pavel Moravec 2016-02-21 08:40:48 UTC
Hi Pep,
could you please respond in upstream discussion to:

https://github.com/sosreport/sos/issues/612#issuecomment-125247694
https://github.com/sosreport/sos/issues/612#issuecomment-172481248

We still lack information when to enable the new plugin, what precisely to collect (some info sos already collects but in different format),..

Thanks.

Comment 11 Eric Rich 2016-02-29 18:53:32 UTC
(In reply to Pavel Moravec from comment #10)
> Hi Pep,
> could you please respond in upstream discussion to:
> 
> https://github.com/sosreport/sos/issues/612#issuecomment-125247694
> https://github.com/sosreport/sos/issues/612#issuecomment-172481248
> 
> We still lack information when to enable the new plugin, what precisely to
> collect (some info sos already collects but in different format),..
> 
> Thanks.

Do we have a draft or PR that start to form the basis for what we are trying to collect for OpenShift? 

I only ask because I am looking for a place to record item that I feel we should be collecting, or that might be helpful to support. For now I will denote items in this bug that I feel should be collected by the sosreport tool. 

The following KCS are good places to start for collecting data: 

https://access.redhat.com/solutions/1542293

For looking at oc commands as a system:admin you can use the following if you are looking to automate commands.

    # oc get pods --config="/etc/openshift/master/admin.kubeconfig"

For getting a list of pods for node in an OSE environment:

    # for node in $(oc get nodes | awk 'NR!=1{print $1}'); do \ 

        oadm manage-node $node --list-pods; 

    done

The same loop could be used to also get the following:

     # oc describe node

What pods can we see if we are on the "master" and have (system:admin) privileges.

    # oc get pods --all-namespaces

Determine infrastructure version information:

    # oc get dc docker-registry -o yaml | grep image: | tr -d " "

I also feel that running or collecting information presented by the following trello cards is important: 

https://trello.com/c/LdUogKuN/73-3-introduce-openshift-v3-diagnostics
https://trello.com/c/On7sLHVw/152-diagnostics
https://trello.com/c/c3Amaijl/88-5-diagnostics-container
https://trello.com/c/HtaFZbiR/68-13-network-diagnostics-utility-supportability
https://trello.com/c/8OxoAsOT/73-5-openshift-ex-diagnostics-deep-dive

https://trello.com/c/F3U1aWRz/75-8-openshift-diagnostics-for-cluster-admin
https://trello.com/c/mlXbW949/74-8-openshift-diagnostics-for-host

We should also be leveraging or updating the following plugins to collect OSE data (where approprate)

https://github.com/sosreport/sos/blob/master/sos/plugins/docker.py
https://github.com/sosreport/sos/blob/master/sos/plugins/kubernetes.py 
   -- We likely need to modify this to also pick up or trigger have OSE trigger data collection using this plugin as OSE is a distribution of kuberneties.

Comment 12 Josep 'Pep' Turro Mauri 2016-03-03 14:13:07 UTC
Related upstream requests:

https://github.com/sosreport/sos/pull/783   specific AP/OSE3 data
https://github.com/sosreport/sos/pull/717   more kubernetes info
https://github.com/sosreport/sos/pull/718   more docker info
https://github.com/sosreport/sos/issues/782 openvswitch data collection

Comment 14 Robert Krátký 2016-04-12 10:50:31 UTC
Hi Pavel,

This bug has been selected for inclusion in 7.3 Release Notes. Could you please add info to the Docs Text field, so that I can use it to formulate the release note?

Perhaps it could be lumped together with bug #1293044?

Thanks.

Comment 17 Robert Krátký 2016-08-21 16:17:45 UTC
Hi Pavel,

Could you please check the Release Notes text?

Thank you.

Comment 20 Pavel Moravec 2016-08-26 15:27:03 UTC
(In reply to Robert Krátký from comment #17)
> Hi Pavel,
> 
> Could you please check the Release Notes text?
> 
> Thank you.

Sounds ok.

> I created https://github.com/sosreport/sos/pull/869 to help get this information included.

To have it in RHEL, please raise also a bugzilla. Due to 7.3 late devel/testing phase, I dont plan to backport this to RHEL7.3 now.

Comment 21 Pavel Moravec 2016-08-29 08:36:26 UTC
(In reply to Pavel Moravec from comment #20)
> (In reply to Robert Krátký from comment #17)
> > Hi Pavel,
> > 
> > Could you please check the Release Notes text?
> > 
> > Thank you.
> 
> Sounds ok.
> 
> > I created https://github.com/sosreport/sos/pull/869 to help get this information included.
> 
> To have it in RHEL, please raise also a bugzilla. Due to 7.3 late
> devel/testing phase, I dont plan to backport this to RHEL7.3 now.

Erich or Pep, is current version (without PR 869) acceptable for RHEL 7.3, or do you need it added to 7.3 GA?

(also note the PR has pep8/formatting issue)

Comment 22 Josep 'Pep' Turro Mauri 2016-08-29 08:39:39 UTC
I believe PR 869 is not needed (will comment on it too):

(In reply to Eric Rich from comment #18)
> 
> In, my tests the code is collecting the things it should, however I think
> from a "diagnostics" view of the world, it would be good to add 2 more
> items: 
> 
> 1: 
> Is there a reason why we are not collecting the openshift version, oc
> version and oadm version commands? 

We have the RPM package version collected by the rpm plugin, and/or the docker image ID/tag for containerized installs collected by the docker plugin.

> It looks like the code for this PR does not collect this when it should. 
> 
> 2: 
> I also see that we are missing information (on nodes) from the master:
> 
> > For getting a list of pods for node in an OSE environment:
> >    # for node in $(oc get nodes | awk 'NR!=1{print $1}'); do \ 
> >       oc describe $node; 
> >    done

The kubernetes plugin collects info about nodes:

  https://github.com/sosreport/sos/blob/3.3/sos/plugins/kubernetes.py#L85-L87

It's not exactly an "oc describe", but if you feel that the information collected by that plugin is not enough I believe we should modify the k8s plugin instead.

> It does not look like the code collects this and it should.

Is there any reason we should collect this explicitly in the openshift plugin in addition to the information already collected by other plugins mentioned above?

Comment 25 errata-xmlrpc 2016-11-04 04:53:52 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2380.html


Note You need to log in before you can comment on or make changes to this bug.