Bug 124647 - Unable to use LVM on EMC PowerPath devices
Unable to use LVM on EMC PowerPath devices
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: lvm (Show other bugs)
3.0
i386 Linux
medium Severity low
: ---
: ---
Assigned To: Heinz Mauelshagen
:
: 113971 (view as bug list)
Depends On:
Blocks: 156321
  Show dependency treegraph
 
Reported: 2004-05-28 02:56 EDT by Rafael 'Dido' Sevilla
Modified: 2007-11-30 17:07 EST (History)
18 users (show)

See Also:
Fixed In Version: RHBA-2005-579
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-28 14:31:52 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rafael 'Dido' Sevilla 2004-05-28 02:56:38 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6)
Gecko/20040429 Firefox/0.8

Description of problem:
We have been attempting to make use of the Linux Logical Volume
Manager on EMC PowerPath pseudo-devices. We are using the 3.0.6
version of the PowerPath driver on an EMC Clariion storage appliance.
 An attempt to create a physical volume on a PowerPath device fails
with an invalid device error.


Version-Release number of selected component (if applicable):
kernel-smp-2.4.21-9.0

How reproducible:
Always

Steps to Reproduce:
1.Create EMC PowerPath devices
2.Attempt to create an LVM physical volume using pvcreate
    

Actual Results:  Invalid device error

Expected Results:  Success of the physical volume creation

Additional info:

We have been advised by EMC that what we are doing is unsupported by
the driver, but we are wondering what other options are available.  Do
other Red Hat ES/AS versions suffer from this difficulty? Are other
volume management solutions usable (e.g. IBM EVMS or others)?
Comment 1 Arjan van de Ven 2004-05-28 03:36:42 EDT
It's probably better if you file a support request for this and not a
bugzilla bug. our support people have the infrastructure to escalate
issues with the EMC binary only kernel modules to EMC, we in 
engineering can't really do that with bugzilla.
Comment 2 Heinz Mauelshagen 2004-05-28 09:13:43 EDT
Covered in lvm-1_0_8-2
Comment 3 Jay Turner 2004-09-01 22:17:46 EDT
An errata has been issued which should help the problem 
described in this bug report. This report is therefore being 
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files, 
please follow the link below. You may reopen this bug report 
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2004-232.html
Comment 4 Tom DuVally 2004-09-17 09:34:40 EDT
Encountered same issue after updating to lvm-1.0.8-5

pvcreate -- invalid physical volume "/dev/emcpowera"
Comment 5 Brian Marsden 2004-09-18 14:34:19 EDT
Me also:

# rpm -q lvm
lvm-1.0.8-5
# ls /dev/emcpowerb*
/dev/emcpowerb    /dev/emcpowerb12  /dev/emcpowerb2  /dev/emcpowerb6
/dev/emcpowerb1   /dev/emcpowerb13  /dev/emcpowerb3  /dev/emcpowerb7
/dev/emcpowerb10  /dev/emcpowerb14  /dev/emcpowerb4  /dev/emcpowerb8
/dev/emcpowerb11  /dev/emcpowerb15  /dev/emcpowerb5  /dev/emcpowerb9
# fdisk -l /dev/emcpowerb

Disk /dev/emcpowerb: 68.3 GB, 68325212160 bytes
255 heads, 63 sectors/track, 8306 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes

         Device Boot    Start       End    Blocks   Id  System
/dev/emcpowerb1             1      8306  66717913+  8e  Linux LVM
# pvcreate /dev/emcpowerb
pvcreate -- invalid physical volume "/dev/emcpowerb"

Also note that lvmdiskscan does not see the emcpower psuedo devices
either (probably the same issue):
# lvmdiskscan
lvmdiskscan -- reading all disks / partitions (this may take a while...)
lvmdiskscan -- /dev/sda1  [     101.94 MB] free whole disk
lvmdiskscan -- /dev/sdb1  [     399.62 GB] free whole disk
lvmdiskscan -- /dev/sdc1  [      63.63 GB] free whole disk
lvmdiskscan -- /dev/sdd1  [        336 GB] free whole disk
lvmdiskscan -- /dev/sde1  [     801.88 GB] free whole disk
lvmdiskscan -- /dev/sdf1  [     764.60 GB] free whole disk
lvmdiskscan -- /dev/sdg1  [     399.62 GB] free whole disk
lvmdiskscan -- /dev/sdh1  [      63.63 GB] free whole disk
lvmdiskscan -- /dev/sdi1  [        336 GB] free whole disk
lvmdiskscan -- /dev/sdj1  [     801.88 GB] free whole disk
lvmdiskscan -- /dev/sdk1  [     764.60 GB] free whole disk
lvmdiskscan -- 11 disks
lvmdiskscan -- 11 whole disks
lvmdiskscan -- 0 loop devices
lvmdiskscan -- 0 multiple devices
lvmdiskscan -- 0 network block devices
lvmdiskscan -- 15 partitions
lvmdiskscan -- 0 LVM physical volume partitions

Comment 6 Schelstraete Bart 2004-09-20 05:51:09 EDT
And same over here..doesn't work.
Comment 8 Brian Marsden 2004-09-26 12:47:37 EDT
I think I have a possible fix:

It seems like the patch makes power2 an invalid parition type as
tested by the switch/case section tools/lib/lvm_check_partitioned.c

    else {
        switch (lvm_get_device_type(st_rdev)) {
        case LVM_DEVICE_TYPE_INVALID:
        case LVM_DEVICE_TYPE_NBD:
        case LVM_DEVICE_TYPE_LOOP:
        case LVM_DEVICE_TYPE_MD:
        case LVM_DEVICE_TYPE_ATARAID:
        case LVM_DEVICE_TYPE_POWER2:
            break;
 
The case LVM_DEVICE_TYPE_POWER2: line simply needs to be removed and
all is rosy. In diff form, something like this:

--- lvm_check_partitioned_dev.c 2004-09-26 17:45:51.000000000 +0100
+++ lvm_check_partitioned_dev_ok.c      2004-09-26 17:47:58.000000000
+0100
@@ -65,7 +65,6 @@
        case LVM_DEVICE_TYPE_LOOP:
        case LVM_DEVICE_TYPE_MD:
        case LVM_DEVICE_TYPE_ATARAID:
-       case LVM_DEVICE_TYPE_POWER2:
            break;
        default:
            ret = TRUE;


Comment 9 Dieter Pape 2004-09-28 03:02:26 EDT
We just installed PowerPath 3.0.7. The problem still exists!
Comment 10 Ruben Alvarez 2004-09-28 12:00:47 EDT
I have the same problem while using PowerPath 3.0.7 with lvm-1.8.0-5
on Red Hat AS 3.0. It doesn't work for me. I have stuck at this point :-(.

pvcreate -- invalid physical volume "/dev/emcpowera"

Will be this issue fixed soon?. Thanks.

Comment 11 Aleksandr Brezhnev 2004-09-30 13:44:24 EDT
The patch described in comment #8 fixes the problem.
I have verified this with PowerPath 3.0.6.
Comment 15 Mike Lewis 2004-10-29 16:47:33 EDT
[root@eabodb01 root]# rpm -q lvm
lvm-1.0.8-5
[root@eabodb01 root]# ls /dev/emcpowera*
/dev/emcpowera    /dev/emcpowera11  /dev/emcpowera14  /dev/emcpowera3
 /dev/emcpowera6  /dev/emcpowera9
/dev/emcpowera1   /dev/emcpowera12  /dev/emcpowera15  /dev/emcpowera4
 /dev/emcpowera7
/dev/emcpowera10  /dev/emcpowera13  /dev/emcpowera2   /dev/emcpowera5
 /dev/emcpowera8
[root@eabodb01 root]# fdisk -l /dev/emcpowera

Disk /dev/emcpowera: 107.3 GB, 107374182400 bytes
255 heads, 63 sectors/track, 13054 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes

         Device Boot    Start       End    Blocks   Id  System
/dev/emcpowera1             1     13054 104856223+  8e  Linux LVM
[root@eabodb01 root]# pvcreate /dev/emcpowera
pvcreate -- invalid physical volume "/dev/emcpowera"

[root@eabodb01 root]# pvcreate /dev/emcpowera1
pvcreate -- invalid physical volume "/dev/emcpowera1"

[root@eabodb01 root]# lvmdiskscan 
lvmdiskscan -- reading all disks / partitions (this may take a while...)
lvmdiskscan -- /dev/sda1         [        100 GB] free whole disk
lvmdiskscan -- /dev/sdb1         [        100 GB] free whole disk
lvmdiskscan -- /dev/sdc1         [        100 GB] free whole disk
lvmdiskscan -- /dev/sdd1         [        100 GB] free whole disk
lvmdiskscan -- /dev/cciss/c0d0p1 [      94.10 MB] free whole disk
lvmdiskscan -- 5 disks
lvmdiskscan -- 5 whole disks
lvmdiskscan -- 0 loop devices
lvmdiskscan -- 0 multiple devices
lvmdiskscan -- 0 network block devices
lvmdiskscan -- 6 partitions
lvmdiskscan -- 0 LVM physical volume partitions

I agree, it does not seem to work.  EMC has been of little help with
this problem.
Comment 27 Heinz Mauelshagen 2004-12-14 05:33:55 EST
Sorry Matt, it took EMC so long...
If the package won't arrive in the next 1-2 days, nothing will happen before
January because of my XMas vacation anyway.
Comment 29 Dan Taylor 2004-12-14 16:08:05 EST
shouldnt this bug be reopened since the fix didnt work?
Comment 30 John Flanagan 2004-12-21 16:09:40 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHEA-2004-589.html
Comment 37 Clif 2005-04-12 03:36:53 EDT
I'm having the exact problem on a newly installed system running lvm-1.0.8-9 on
RHES3?!  Is there a patch, etc.?
Comment 38 Heinz Mauelshagen 2005-04-12 05:52:41 EDT
Fix will be part of U5.
Comment 39 Clif 2005-04-12 12:24:16 EDT
(In reply to comment #38)
> Fix will be part of U5

There won't be an update prior??? I'm dead in the water now!  Please, is there a
patch, etc. I can apply now?  How long until U5 is out?
Comment 40 Clif 2005-04-12 15:33:01 EDT
I've verified the bug still exists with lvm-1.0.8-12.2 obtained from the beta
channel.
Comment 41 Clif 2005-04-13 10:58:00 EDT
For me, the problem was caused by LVM not recognizing the volume being called by
the path /dev/emcpowera and/or /dev/emcpowera1.  Being that I'm not clustering
and I don't need the functionality provided by EMC's app/wrapper PowerPath, I
uninstalled it and used the standard device name /dev/sdX.
Comment 66 Rafael Koike 2005-05-06 09:07:29 EDT
(In reply to comment #39)
> (In reply to comment #38)
> > Fix will be part of U5
> There won't be an update prior??? I'm dead in the water now!  Please, is 
there a
> patch, etc. I can apply now?  How long until U5 is out?

I have made a fix that works for me.

Looking in the code, i found the folow fix in lvm-1.0.8-9-power2.patch:

--- LVM/1.0.8/tools/lib/lvm_check_partitioned_dev.c.power2      Wed Oct 20 
10:51:20 2004
+++ LVM/1.0.8/tools/lib/lvm_check_partitioned_dev.c     Wed Oct 20 10:53:33 2004
@@ -65,7 +65,6 @@
        case LVM_DEVICE_TYPE_LOOP:
        case LVM_DEVICE_TYPE_MD:
        case LVM_DEVICE_TYPE_ATARAID:
-       case LVM_DEVICE_TYPE_POWER2:
            break;
        default:
            ret = TRUE;
@@ -165,6 +164,7 @@
        { "ataraid", LVM_DEVICE_TYPE_ATARAID }, /* ATA Raid                  */
         { "viod", LVM_DEVICE_TYPE_VIODASD }, /* viodasd                      */
         { "i2o_block", LVM_DEVICE_TYPE_I2O },/* i2o disk                     */
+        { "emcpower", LVM_DEVICE_TYPE_POWER2 },/* PowerPath                  */
         { "power2", LVM_DEVICE_TYPE_POWER2 },/* PowerPath                    */
         { "emd", LVM_DEVICE_TYPE_EMD }, /* Enhanced MD                       */
         { "sx8", LVM_DEVICE_TYPE_SX8 }, /* Promise SX8 SATA                  */


The complete code read the /proc/devices (like: cat /proc/devices ) and check 
every device in this list if they match with the above array.

The situation is that in /proc/devices the powerpath show as "emcp" instead of 
emcpower,

My fix is change this:
+        { "emcpower", LVM_DEVICE_TYPE_POWER2 },/* PowerPath                  */

to this:
+        { "emcp", LVM_DEVICE_TYPE_POWER2 },/* PowerPath                  */

My rebuild work for partitions (like: emcpowerb1) but don't work for disks 
emcpowerb

But i don't see any problem in creating a entire disk partition type 8e (Linux 
LVM)

Comment 96 Pierre Wendling 2005-07-27 07:15:17 EDT
Any news on this ?

It is not fixed in lvm-1.0.8-12.2 (Update 5).

We've hand patched using the fix from the comment #66, but we'd like an
official/supported/easily installable fix.
Comment 97 Heinz Mauelshagen 2005-07-27 08:15:03 EDT
Pierre,

the fix from #66 will be included in the next release.
Comment 98 Rob Kenna 2005-07-27 09:52:19 EDT
Yes, RHEL 3, Update 2 will have this fix.
Comment 99 Rob Kenna 2005-07-27 10:02:40 EDT
I meant, RHEL 3, Update 6
Comment 100 Heinz Mauelshagen 2005-07-28 04:41:35 EDT
*** Bug 113971 has been marked as a duplicate of this bug. ***
Comment 105 Red Hat Bugzilla 2005-09-28 14:31:52 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2005-579.html

Note You need to log in before you can comment on or make changes to this bug.