Bug 124656 - PowerBook G3 WallStreet needs PCMCIA eject support
PowerBook G3 WallStreet needs PCMCIA eject support
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
powerpc Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
Brian Brock
: FutureFeature
Depends On:
Blocks: fedora-ppc
  Show dependency treegraph
 
Reported: 2004-05-28 05:34 EDT by Barry K. Nathan
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-07-10 06:37:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
lycestra.com pcmcia.patch (in case the original URL dies) (3.75 KB, patch)
2005-06-06 05:58 EDT, Barry K. Nathan
no flags Details | Diff

  None (edit)
Description Barry K. Nathan 2004-05-28 05:34:06 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux ppc; en-US; rv:1.6)
Gecko/20040523 Firefox/0.8

Description of problem:
On Apple PowerBook G3's of the "WallStreet" variety, some kind of
patch(es) is needed to properly eject PCMCIA and CardBus cards. The
WallStreet PCMCIA slots have motorized eject (much like the old Apple
3.5" floppy drives used to).

Without the appropriate modifications, the only other approaches are
to yank the card out of the slot (which I did until I wrecked an
Ethernet cable that way earlier this week) or to use the eccentric
tool known as an unbent paper clip (this works in much the same manner
as emergency eject of a CD-ROM).

I have found conflicting information on the 'Net; the package which
needs to be patched is either kernel or pcmcia-cs (or both). I don't
yet know if the patch(es) is suitable for inclusion in Fedora Core.

Since Yellow Dog 4 isn't out yet, I don't know how it handles this
situation. I've never tried Debian or Gentoo on this machine (maybe I
should sometime). IIRC (and I may not), PCMCIA eject didn't work under
Yellow Dog 3.0 either.


Version-Release number of selected component (if applicable):
kernel-2.6.5-1.358
pcmcia-cs-3.2.7-1.5

How reproducible:
Always

Steps to Reproduce:
1. cardctl eject <socket number>

Actual Results:  Card shuts off but is stuck in the socket

Expected Results:  Card is ejected

Additional info:

Even though it's not an official release, IMO FC2 on PPC is the first
truly excellent PPC distribution since Yellow Dog Champion Server 1.2.
In that context, this bug is clearly minor.

If I end up having to do all the major work on this bug, that's OK,
but it may be a few weeks before I have the time. In any event, I want
to get this filed in Bugzilla now.
Comment 1 David Woodhouse 2004-05-28 06:11:53 EDT
This would be a kernel feature -- it needs to get implemented in the
upstream kernel first and then it'll just start working in Fedora.
Comment 2 Barry K. Nathan 2004-05-30 22:22:26 EDT
FWIW, from this page:
http://www.lycestra.com/sys.html
I found this patch:
http://www.lycestra.com/dev/2.4/pcmcia.patch

It doesn't apply cleanly to recent 2.4 (I tried against 2.4.27-pre4).
If I try to apply it to 2.6.6-1.397 it tries to patch a file that
doesn't even exist anymore.

However, it may still be a good starting point for developing a 2.6
patch, if nobody else has done so yet.

If nobody else does any work on this, I'll probably have to postpone
working on this for a month or two. (I have no problem with that,
however.)
Comment 3 Barry K. Nathan 2004-07-10 06:37:45 EDT
My PowerBook G3 recently became my dad's new office computer, so I now
have no way of testing a patch anytime in the near future (and I
wouldn't want to try making a patch for this without being able to
test it). In the not-so-near future, I may end up getting the machine
back the next time he upgrades and I may use it for running Linux again.

I'm not completely sure how I should close this bug; DEFERRED is my
best guess...
Comment 4 Barry K. Nathan 2005-06-06 05:58:02 EDT
Created attachment 115161 [details]
lycestra.com pcmcia.patch (in case the original URL dies)

This patch applies against some version of 2.4. In fact, it's against ancient
2.4 and IIRC doesn't even apply to current 2.4 anymore. But this may still be a
useful reference for anyone who wants to tackle this in the future. (However,
that won't be me. See my next comment on this bug.)
Comment 5 Barry K. Nathan 2005-06-06 06:17:33 EDT
Oops, I already said earlier in this bug that the patch doesn't apply to current
2.4.

Anyway, picking up where comment #3 left off... I no longer have functioning
"WallStreet" PowerBook G3 hardware, and this is now permanent. Therefore I can't
test a fix, so I won't bother trying to fix it. Ergo, I'm changing this bug from
DEFERRED to WONTFIX.

If anyone else wants to fix this in the future, I guess you should clone this
bug (if possible) or file a new bug.

Note You need to log in before you can comment on or make changes to this bug.