Bug 124657 - Mac images stopped being generated
Mac images stopped being generated
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
powerpc Linux
medium Severity medium
: ---
: ---
Assigned To: Elliot Lee
Mike McLean
http://download.fedora.redhat.com/pub...
:
Depends On:
Blocks: fedora-ppc
  Show dependency treegraph
 
Reported: 2004-05-28 06:03 EDT by Colin Charles
Modified: 2007-11-30 17:10 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-02-06 01:22:04 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Colin Charles 2004-05-28 06:03:00 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6)
Gecko/20040510 Epiphany/1.2.4

Description of problem:
The images/ directory is now totally empty, meaning no bootable
installer is being found

From a working good tree, there should be "mac" and "pseries" as
sub-directories, and a boot.iso to allow installation from the latest
tree.

This is currently unavailable, and is possibly a bug in the build scripts.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Visit
http://download.fedora.redhat.com/pub/fedora/linux/core/development/ppc/images/

    

Actual Results:  2. Its empty

Expected Results:  It contains 2 sub-directories - mac, pseries.
Inside each, a boot.iso will exist.

Additional info:
Comment 1 Jeremy Katz 2004-06-01 15:23:08 EDT
Just random tree wonkiness with build machines going bad.  It happens,
new build machine has been set up now which should hopefully help
things a bit.
Comment 2 David Woodhouse 2004-06-03 09:44:53 EDT
Images still absent. Failure mode seems deterministic:

[03Jun2004 05:50:36] Traceback follows for ppc
Traceback (most recent call last):
[03Jun2004 05:50:36] Traceback follows for ppc
File "/mnt/redhat/test/rel-eng/builddistro/builddistro.py", line 1368,
in logTB
    apply(tb_run, args, kwargs)
[03Jun2004 05:50:36] Traceback follows for ppc
File "/mnt/redhat/test/rel-eng/builddistro/multiarchtree.py", line
204, in composeMultiArch
    "%s/%s/%s/RPMS/%s" %(self.getArchDir(thearch),
[03Jun2004 05:50:36] Traceback follows for ppc
OSError: [Errno 17] File exists
Comment 3 Paul Nasrat 2004-06-21 10:17:58 EDT
Reassigning to rel-eng.
Comment 4 Paul Nasrat 2004-06-23 07:46:08 EDT
hdlist generation seems to be failing:

[23Jun2004 05:00:14] Composing dist-rawhide/ppc in rawhide-20040623
[23Jun2004 05:07:46] Compose for dist-rawhide on ppc finished
[23Jun2004 05:09:07] Exploding anaconda-runtime
(/mnt/redhat/nightly/rawhide-20040623/ppc/Fedora/RPMS/anaconda-runtime-10.0.1-0.20040621190954.ppc.rpm)
for ppc
[23Jun2004 05:09:23] Exploding comps-extras
(/mnt/redhat/nightly/rawhide-20040623/ppc/Fedora/RPMS/comps-extras-9.92-1.noarch.rpm)
for ppc
[23Jun2004 05:09:31] Exploding anaconda
(/mnt/redhat/nightly/rawhide-20040623/ppc/Fedora/RPMS/anaconda-10.0.1-0.20040621190954.ppc.rpm)
for ppc
[23Jun2004 05:10:06] Exploding fedora-release
(/mnt/redhat/nightly/rawhide-20040623/ppc/Fedora/RPMS/fedora-release-2-rawhide.noarch.rpm)
for ppc
[23Jun2004 05:10:08] Checking out comps file for ppc
[23Jun2004 05:10:09] Got comps/comps-fc3.xml for ppc
[23Jun2004 05:10:09] Generating compose hdlist for ppc
[23Jun2004 05:10:09] Composing multilib for ppc (ppc64)
[23Jun2004 05:10:14] Traceback follows for ppc
Traceback (most recent call last):
[23Jun2004 05:10:14] Traceback follows for ppc
File "/mnt/redhat/scripts/rel-eng/builddistro/builddistro.py", line
1368, in logTB
    apply(tb_run, args, kwargs)
[23Jun2004 05:10:14] Traceback follows for ppc
File "/mnt/redhat/scripts/rel-eng/builddistro/multiarchtree.py", line
72, in composeMultiArch
    fd = os.open(hdlist_path + 'hdlist', os.O_RDONLY)
[23Jun2004 05:10:14] Traceback follows for ppc
OSError: [Errno 2] No such file or directory:
'/mnt/redhat/nightly/rawhide-20040623/ppc/Fedora/base/hdlist'
Comment 5 Paul Nasrat 2004-07-05 09:02:39 EDT
As if by magic :)

ftp://download.fedora.redhat.com/pub/fedora/linux/core/development/ppc/images/mac/boot.iso

I just did a build myself and was going to add a comment that that
seemed OK.  Checking we now have rawhide ppc boot images.
Comment 6 Barry K. Nathan 2004-07-10 05:09:10 EDT
The rawhide ppc boot images seem to be gone again...
Comment 7 Paul Nasrat 2004-07-10 05:27:17 EDT
Different issue - probably just tree breakage in rawhide:

[09Jul2004 05:39:04] Package mismatches exist on ppc
[09Jul2004 05:40:33] CRITICAL ERROR : Broken deps exist on ppc
[09Jul2004 05:40:33] No package conflicts on ppc
Comment 8 Elliot Lee 2004-07-16 12:43:03 EDT
Broken deps will be there on-and-off - it's up to the package
maintainers to fix them.
Comment 9 David Woodhouse 2004-08-06 06:39:34 EDT
Doesn't seem to be dependencies. There's bizarre stuff happening.
First we see this while running buildinstall...

Removing unused python files in hdimage... WARNING: Unique disk
signatures don't exist
* setting file_context_path to nil
rm: cannot remove `/tmp/treedir.32288/image-template/./biosdisk of 80
is None':
No such file or directory


... then the line 'biosdisk of 80 is None' appears to be in the
generated pkgorder file, and genhdlist barfs:

genhdlist: FATAL ERROR -> "biosdisk of 80 is None" is not a package name!!
Your package list file
/mnt/redhat/nightly/rawhide-20040806/ppc-logs/pkgorder.19032 is most
likely CORRUPT!
Comment 10 Bill Nottingham 2004-08-06 11:12:51 EDT
Fixed.
Comment 11 Colin Charles 2004-11-23 01:00:13 EST
Re-opening, it has disappeared again :)
Comment 12 Colin Charles 2004-11-23 01:01:11 EST
Re-opening, it has disappeared again :)
Comment 13 Colin Charles 2005-02-06 01:22:04 EST
Fixed, its back for FC-4 test 1 timeframe

Note You need to log in before you can comment on or make changes to this bug.