Bug 124667 - RFE: compile devlabel with dietlibc for use in initrd
RFE: compile devlabel with dietlibc for use in initrd
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: devlabel (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-05-28 08:57 EDT by Harald Hoyer
Modified: 2014-03-16 22:45 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-06-07 05:18:06 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch for the utils to compile with dietlibc (9.13 KB, patch)
2004-05-28 08:57 EDT, Harald Hoyer
no flags Details | Diff

  None (edit)
Description Harald Hoyer 2004-05-28 08:57:19 EDT
for a better initrd (with udev) it would be nice to also include devlabel.
with the attached patch this is possible to build with diet

%build
-gcc $RPM_OPT_FLAGS -o scsi_unique_id scsi_unique_id.c
-gcc $RPM_OPT_FLAGS -o partition_uuid -luuid partition_uuid.c
+diet gcc $RPM_OPT_FLAGS -o scsi_unique_id scsi_unique_id.c
+diet gcc $RPM_OPT_FLAGS -o partition_uuid partition_uuid.c -luuid
Comment 1 Harald Hoyer 2004-05-28 08:57:54 EDT
Created attachment 100658 [details]
patch for the utils to compile with dietlibc
Comment 2 Bill Nottingham 2004-05-28 12:18:46 EDT
Why not just enhance udev with libuuid support (and its own scsi
identifier)?

The guts of devlabel (the shell script bits) are pretty much
irrelevant with udev.

In fact, scsi_id in extras/ in udev seems to be more or less the same
thing as scsi_unique_id.

Note You need to log in before you can comment on or make changes to this bug.