Bug 1246728 - client3_3_removexattr_cbk floods the logs with "No data available" messages
Summary: client3_3_removexattr_cbk floods the logs with "No data available" messages
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: logging
Version: 3.7.2
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Niels de Vos
QA Contact:
URL:
Whiteboard:
Depends On: 1246736
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-07-25 05:09 UTC by Con Tassios
Modified: 2015-07-30 09:50 UTC (History)
3 users (show)

Fixed In Version: glusterfs-3.7.3
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 1246736 (view as bug list)
Environment:
Last Closed: 2015-07-30 09:50:10 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Con Tassios 2015-07-25 05:09:41 UTC
Similar problem to https://bugzilla.redhat.com/show_bug.cgi?id=1188064

With log-level set to ERROR, I still get logs like this

[2015-07-25 02:06:11.206465]  [MSGID: 114031] [client-rpc-fops.c:1300:client3_3_removexattr_cbk] 0-gv0-client-0: remote operation failed: No data available [No data available]                   

I notice that xlators/protocol/client/src/client-rpc-fops.c line 1293 of 3.7.2 source, loglevel is set to 0.  The 3.6.4 source set this to GF_LOG_DEBUG.

Comment 1 Anand Avati 2015-07-25 08:58:06 UTC
REVIEW: http://review.gluster.org/11760 (logging: client3_3_removexattr_cbk should not log expected ENODATA) posted (#1) for review on release-3.7 by Niels de Vos (ndevos@redhat.com)

Comment 2 Anand Avati 2015-07-26 08:10:53 UTC
COMMIT: http://review.gluster.org/11760 committed in release-3.7 by Niels de Vos (ndevos@redhat.com) 
------
commit 285d1c851d18bcd7e7a2c48f440bbe107d260dca
Author: Niels de Vos <ndevos@redhat.com>
Date:   Sat Jul 25 10:47:03 2015 +0200

    logging: client3_3_removexattr_cbk should not log expected ENODATA
    
    Commit 379dbbfd changed the log level of an expected error message from
    GF_LOG_DEBUG to '0'. This causes the message to always get logged. It is
    intended to log the warning when the xattr could not be removed (but
    exists), removing a non-existing xattr is sufficient as debug.
    
    Backported from:
    > BUG: 1246736
    > Change-Id: If11d15d699e8152cc32e0c0c1d65b587c5c48892
    > Reviewed-on: http://review.gluster.org/11759
    > Signed-off-by: Niels de Vos <ndevos@redhat.com>
    
    Change-Id: If11d15d699e8152cc32e0c0c1d65b587c5c48892
    BUG: 1246728
    Signed-off-by: Niels de Vos <ndevos@redhat.com>
    Reviewed-on: http://review.gluster.org/11760
    Tested-by: NetBSD Build System <jenkins@build.gluster.org>
    Reviewed-by: Joe Julian <me@joejulian.name>
    Tested-by: Joe Julian <me@joejulian.name>
    Tested-by: Gluster Build System <jenkins@build.gluster.com>

Comment 3 Kaushal 2015-07-30 09:50:10 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.3, please open a new bug report.

glusterfs-3.7.3 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/12078
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user


Note You need to log in before you can comment on or make changes to this bug.