Bug 1246782 - marker: fix memory freeing order
Summary: marker: fix memory freeing order
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: GlusterFS
Classification: Community
Component: quota
Version: mainline
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Prasanna Kumar Kalever
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-07-25 18:28 UTC by Prasanna Kumar Kalever
Modified: 2015-12-21 09:03 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-12-21 09:03:53 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Prasanna Kumar Kalever 2015-07-25 18:28:12 UTC
Description of problem:
Memory leak prone due to incorrect way of ordering labels that free memory  

Version-Release number of selected component (if applicable):
mainline

How reproducible:
always

Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Anand Avati 2015-07-25 18:31:45 UTC
REVIEW: http://review.gluster.org/11761 (marker: fix memory freeing order) posted (#1) for review on master by Prasanna Kumar Kalever

Comment 2 Anand Avati 2015-07-25 21:32:31 UTC
REVIEW: http://review.gluster.org/11761 (marker: fix memory freeing order) posted (#2) for review on master by Prasanna Kumar Kalever

Comment 3 Vijaikumar Mallikarjuna 2015-12-21 09:03:53 UTC
patch http://review.gluster.org/11761 is Abandoned.

The issue mentioned in description is in un-used code which is cleaned in the latest release.
So closing the bug


Note You need to log in before you can comment on or make changes to this bug.