Bug 1246784 - SELinux is preventing abrt-hook-ccpp from using the 'sigchld' accesses on a process.
Summary: SELinux is preventing abrt-hook-ccpp from using the 'sigchld' accesses on a p...
Keywords:
Status: CLOSED DUPLICATE of bug 1245477
Alias: None
Product: Fedora
Classification: Fedora
Component: selinux-policy
Version: 22
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Miroslav Grepl
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:7234b32953f3facd59ad426efd7...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-07-25 18:56 UTC by Johannes
Modified: 2015-08-15 15:51 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-08-15 15:51:55 UTC
Type: ---


Attachments (Terms of Use)

Description Johannes 2015-07-25 18:56:44 UTC
Description of problem:
System unresponsive
Hard reset
SELinux is preventing abrt-hook-ccpp from using the 'sigchld' accesses on a process.

*****  Plugin catchall (100. confidence) suggests   **************************

If je denkt dat abrt-hook-ccpp standaard sigchld toegang moet hebben tot processen gelabeld met kernel_t.
Then je moet dit melden als een fout.
Je kunt een locale tactiek module genereren om deze toegang toe te staan.
Do
sta deze toegang nu toe door het uitvoeren van:
# grep abrt-hook-ccpp /var/log/audit/audit.log | audit2allow -M mypol
# semodule -i mypol.pp

Additional Information:
Source Context                system_u:system_r:fprintd_t:s0
Target Context                system_u:system_r:kernel_t:s0
Target Objects                Unknown [ process ]
Source                        abrt-hook-ccpp
Source Path                   abrt-hook-ccpp
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           
Target RPM Packages           
Policy RPM                    selinux-policy-3.13.1-128.6.fc22.noarch
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Enforcing
Host Name                     (removed)
Platform                      Linux (removed) 4.0.8-300.fc22.x86_64 #1 SMP Fri
                              Jul 10 21:04:56 UTC 2015 x86_64 x86_64
Alert Count                   1
First Seen                    2015-07-25 20:47:14 CEST
Last Seen                     2015-07-25 20:47:14 CEST
Local ID                      9c95a86f-bc34-42e2-8427-563c4297c63a

Raw Audit Messages
type=AVC msg=audit(1437850034.112:549): avc:  denied  { sigchld } for  pid=2721 comm="abrt-hook-ccpp" scontext=system_u:system_r:fprintd_t:s0 tcontext=system_u:system_r:kernel_t:s0 tclass=process permissive=0


Hash: abrt-hook-ccpp,fprintd_t,kernel_t,process,sigchld

Version-Release number of selected component:
selinux-policy-3.13.1-128.6.fc22.noarch

Additional info:
reporter:       libreport-2.6.1
hashmarkername: setroubleshoot
kernel:         4.0.8-300.fc22.x86_64
type:           libreport

Comment 1 Vít Ondruch 2015-07-27 07:23:05 UTC
Description of problem:
This appeared after wake up from sleep.

Version-Release number of selected component:
selinux-policy-3.13.1-128.6.fc22.noarch

Additional info:
reporter:       libreport-2.6.1
hashmarkername: setroubleshoot
kernel:         4.0.8-300.fc22.x86_64
type:           libreport

Comment 2 Ting-Wei Lan 2015-08-11 15:24:25 UTC
Description of problem:
This usually happens when I login my system or unlock my screen. fprintd crashes very often on this system because of driver issues.

fprintd[8931]: fprintd: drivers/vfs301_proto.c:102: usb_send: Assertion `r == 0' failed.
systemd[1]: fprintd.service: main process exited, code=dumped, status=6/ABRT
systemd[1]: Unit fprintd.service entered failed state.
systemd[1]: fprintd.service failed.

Version-Release number of selected component:
selinux-policy-3.13.1-128.8.fc22.noarch

Additional info:
reporter:       libreport-2.6.2
hashmarkername: setroubleshoot
kernel:         4.1.3-201.fc22.x86_64
type:           libreport

Comment 3 Miroslav Grepl 2015-08-15 15:51:55 UTC

*** This bug has been marked as a duplicate of bug 1245477 ***


Note You need to log in before you can comment on or make changes to this bug.