Bug 124689 - Machine hang triggered by mkisofs
Summary: Machine hang triggered by mkisofs
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel   
(Show other bugs)
Version: 2
Hardware: i686
OS: Linux
medium
high
Target Milestone: ---
Assignee: Arjan van de Ven
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-05-28 15:07 UTC by Bert DeKnuydt
Modified: 2007-11-30 22:10 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-06-15 12:23:47 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Bert DeKnuydt 2004-05-28 15:07:51 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040115

Description of problem:

Running mkisofs, with option '-h' results in a machine hang.

Input and can be either from NFS or local disk.  Input has
to be at least abt. 50 MB large.  Typically, when 95 to 99% 
is done (as says the -v option), the program stalls, and 
consumes 100% CPU.  No extra memory seems to be consumed.
A few seconds later, the machine grinds to a halt completely.
No swapping noise, no disk io.

It does not happen always, but definitely more than 90% of the
time.  Without option '-h', all works perfectly.

An strace reported a 'munmap' as the last syscall.



Version-Release number of selected component (if applicable):
kernel-smp-2.6.5-1.358 and mkisofs-2.01-0.a27.3

How reproducible:
Sometimes

Steps to Reproduce:
1. Choose a directory tree with abt. 50 MB or more.
2. mkisofs -v -h -o rubbish.iso <this_directory_tree>
3. Wait for 95% finished.
4. Hang...
    

Actual Results:  
The machine uses 100% CPU (Which I could see running it on an SMP).
This lasts for a short time (seconds).  Then there's a complete freeze.

Expected Results:  
Mkisofs should have exited normally.  Or if need be crash.  But should
never trigger a machine hang.

Additional info:

Comment 1 Bert DeKnuydt 2004-06-02 14:28:14 UTC
Update: with kernel-2.6.6-1.406, I can no longer trigger it; but
in SMP with kernel-smp-2.6.6-1.406 it is still present.

Comment 2 Bert DeKnuydt 2004-06-07 09:00:47 UTC
Update: kernel-2.6.6-1.422 seems not to have it. kernel-smp-2.6.6-1.422
in SMP still has it, though slightly differently:  the mkisofs-process
goes into 100% system, is un-interrruptible; console of machine is
dead, but remote access to the machine is okay.  Hard reboot is still
necessary though.  

Comment 3 Bert DeKnuydt 2004-06-14 10:44:25 UTC
We're at 2.6.6-1.427smp now, with mkisofs-2.01-0.a27.4.  Still getting 
a 100% CPU un-interruptible proces.  Not getting any wiser from the
/proc info for that process neither.

Comment 4 Bert DeKnuydt 2004-06-15 11:16:57 UTC
A collegue of mine figured out that the 4G/4G patch is the culprit:
without it, no problems.

Comment 5 Arjan van de Ven 2004-06-15 11:18:57 UTC
we fixed a rare cornercase in the 4g/4g patch in 435 kernel (out as
erratum now) that may explain this....


Comment 6 Bert DeKnuydt 2004-06-15 12:23:47 UTC
Yap, problem fixed in 2.6.6-1.435smp, thanks!


Note You need to log in before you can comment on or make changes to this bug.