Bug 124696 - disklabel script trips on non-existing files
disklabel script trips on non-existing files
Status: CLOSED DUPLICATE of bug 124442
Product: Fedora
Classification: Fedora
Component: devlabel (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-05-28 12:03 EDT by Michal Jaegermann
Modified: 2014-03-16 22:45 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:03:51 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michal Jaegermann 2004-05-28 12:03:15 EDT
Description of problem:

'devlabel' script is using
IGNORE_LIST=/etc/sysconfig/devlabel.d/ignore_list
LAST_LIST=/etc/sysconfig/devlabel.d/proc_partitions
without checking for their existence but no package
provides these files, even empty, nor even
/etc/sysconfig/devlabel.d. Running 'rpm -ql devlabel | grep etc'
gives only /etc/sysconfig/devlabel

With a use of constructs like:

    if [ `grep -c "$1$" $IGNORE_LIST` -gt 0 ]; then
        return 1
    fi

and not even

    if [ `grep -c "$1$" $IGNORE_LIST /dev/null` -gt 0 ]; then
        return 1
    fi

comes a flood of error messages like

/sbin/devlabel: line 129: [: -gt: unary operator expected

and multiple "No such file or directory".

Version-Release number of selected component (if applicable):
devlabel-0.48.01-2
Comment 1 Bill Nottingham 2004-05-28 12:15:22 EDT

*** This bug has been marked as a duplicate of 124442 ***
Comment 2 Red Hat Bugzilla 2006-02-21 14:03:51 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.