Bug 1246989 - possibly duplicate options "--root-pass" and "--root-password" in `hammer host create`
Summary: possibly duplicate options "--root-pass" and "--root-password" in `hammer hos...
Keywords:
Status: CLOSED NEXTRELEASE
Alias: None
Product: Red Hat Satellite
Classification: Red Hat
Component: Hammer
Version: 6.1.0
Hardware: Unspecified
OS: Unspecified
unspecified
low
Target Milestone: Unspecified
Assignee: Tomas Strachota
QA Contact: Katello QA List
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-07-27 06:13 UTC by Jan Hutař
Modified: 2019-08-12 14:38 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-08-01 19:57:53 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Foreman Issue Tracker 18337 None None None 2017-02-01 11:19:34 UTC

Description Jan Hutař 2015-07-27 06:13:55 UTC
Description of problem:
There are possibly duplicate options "--root-pass" and "--root-password" in `hammer host create`. Their "--help" message do not explain whay there should be two of them.


Version-Release number of selected component (if applicable):
Satellite-6.1.0-RHEL-6-20150721.7-Satellite-x86_64


How reproducible:
always


Steps to Reproduce:
1. # hammer host create --help | grep -- "--root"


Actual results:
There are two options for one password (or if these options differ, docs is not sufficient):
 --root-pass ROOT_PASS                                  required if host is managed and value is not inherited from host group or
 --root-password ROOT_PW


Expected results:
There should be only one option for one password.

Comment 2 Bryan Kearney 2016-07-08 20:46:57 UTC
Per 6.3 planning, moving out non acked bugs to the backlog

Comment 4 Tomas Strachota 2017-02-01 11:19:32 UTC
Created redmine issue http://projects.theforeman.org/issues/18337 from this bug

Comment 5 pm-sat@redhat.com 2017-02-01 13:11:26 UTC
Upstream bug assigned to tstrachota@redhat.com

Comment 6 pm-sat@redhat.com 2017-02-01 13:11:29 UTC
Upstream bug assigned to tstrachota@redhat.com

Comment 7 pm-sat@redhat.com 2017-02-23 09:11:07 UTC
Moving this bug to POST for triage into Satellite 6 since the upstream issue http://projects.theforeman.org/issues/18337 has been resolved.

Comment 8 Bryan Kearney 2017-08-01 19:57:53 UTC
The fix to this bug will be delivered with release 6.3 of Satellite.


Note You need to log in before you can comment on or make changes to this bug.