Bug 1246993 - [virtio-win][svvp][ws2016] job "Signed Driver Check (CheckLogo)" failed during ws2016 svvp test
Summary: [virtio-win][svvp][ws2016] job "Signed Driver Check (CheckLogo)" failed durin...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: virtio-win
Version: 7.2
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: rc
: ---
Assignee: Vadim Rozenfeld
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On:
Blocks: 1288337
TreeView+ depends on / blocked
 
Reported: 2015-07-27 06:37 UTC by lijin
Modified: 2016-11-04 08:47 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
NO_DOCS
Clone Of:
Environment:
Last Closed: 2016-11-04 08:47:54 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:2609 normal SHIPPED_LIVE virtio-win bug fix and enhancement update 2016-11-03 15:27:12 UTC

Description lijin 2015-07-27 06:37:31 UTC
Description of problem:

Version-Release number of selected component (if applicable):
qemu-kvm-rhev-2.3.0-6.el7.x86_64
kernel-3.10.0-287.el7.x86_64
virtio-win-prewhql-105/virtio-win-1.7.4-1.el7.noarch
seabios-1.7.5-9.el7.x86_64

How reproducible:
100%

Steps to Reproduce:
1.boot guest with:
/usr/libexec/qemu-kvm -name 105BLKW10S64DZ1 -enable-kvm -m 6G -smp 8 -uuid 3f38f0c1-ed9e-4ed8-93d6-16768f272366 -nodefconfig -nodefaults -chardev socket,id=charmonitor,path=/tmp/105BLKW10S64DZ1,server,nowait -mon chardev=charmonitor,id=monitor,mode=control -rtc base=localtime,driftfix=slew -boot order=cd,menu=on -device piix3-usb-uhci,id=usb,bus=pci.0,addr=0x1.0x2 -drive file=105BLKW10S64DZ1,if=none,id=drive-ide0-0-0,format=raw,serial=mike_cao,cache=none -device virtio-blk-pci,drive=drive-ide0-0-0,id=ide0-0-0 -drive file=105BLKW10S64DZ1.vfd,if=none,id=drive-fdc0-0-0,format=raw,cache=none -global isa-fdc.driveA=drive-fdc0-0-0 -netdev tap,script=/etc/qemu-ifup1,downscript=no,id=hostnet0 -device virtio-net-pci,netdev=hostnet0,id=net0,mac=00:52:1d:16:05:b2 -chardev pty,id=charserial0 -device isa-serial,chardev=charserial0,id=isa_serial0 -device usb-tablet,id=input0 -vnc 0.0.0.0:0 -vga cirrus -cpu Nehalem,+fsgsbase -cdrom /usr/share/virtio-win/virtio-win.iso -device nec-usb-xhci,id=ehci0 -drive file=usb-storage-AMD-max.raw,if=none,id=drive-usb-2-0,media=disk,format=raw,cache=none,werror=stop,rerror=stop,aio=threads -device usb-storage,bus=ehci0.0,drive=drive-usb-2-0,id=usb-2-0,removable=on

2.submit job in HLK

Actual results:
job failed with 
1."Failed to find a catalog file that verifies driver file c:\windows\inf\oem2.inf."
2.Problem: "Not certified for this version of Windows": This file, which is part of a driver package, is certified, but for a different operating system..
Solution: Contact the driver vendor for the correctly signed driver package for the installed operating system and install that driver package..
3.Problem: "Untrusted Driver": No catalog file was found for this file, which is part of a driver package. Due to the unavailability of a catalog file, the trust level could not be evaluated..
Solution: Either try reinstalling this driver package or obtain a new driver package from your driver vendor and install that..


Expected results:
job can pass

Additional info:
tried with virtio-win-1.7.4-1.el7.noarch,job still failed.
I guess job can pass after del sign driver with ws2016 OS

Comment 19 Amnon Ilan 2016-08-30 16:00:41 UTC
The qemu bz for it is bug#1368153

Comment 20 Marcel Apfelbaum 2016-08-31 09:35:27 UTC
Can you please check it this brew build solves the problem?

https://brewweb.engineering.redhat.com/brew/taskinfo?taskID=11683896

Thanks,
Marcel

Comment 21 lijin 2016-09-01 05:28:49 UTC
(In reply to Marcel Apfelbaum from comment #20)
> Can you please check it this brew build solves the problem?
> 
> https://brewweb.engineering.redhat.com/brew/taskinfo?taskID=11683896

the device is disappeared with this build

Thanks,Marcel

Comment 22 Yu Wang 2016-09-18 09:30:28 UTC
Hi,

Re-tested with the latest qemu (qemu-kvm-rhev-2.6.0-25) and virtio-win-1.9.0-2.el7, this job has been passed on both amd and intel host.

So this bug has been fixed.

Note: there is "HID Button over Interrupt driver" in device manager, must uninstall it in advance to pass this job.

Thanks
Yu Wang

Comment 23 lijin 2016-09-20 01:49:46 UTC
As for the "HID Button over Interrupt driver" issue,bug1377155 will track it.

change status to verified according to comment#22

Comment 25 errata-xmlrpc 2016-11-04 08:47:54 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2609.html


Note You need to log in before you can comment on or make changes to this bug.