Bug 1247019 - must enable fence device naming workaround
Summary: must enable fence device naming workaround
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: rhosp-director
Version: Director
Hardware: x86_64
OS: Unspecified
low
low
Target Milestone: rc
: 11.0 (Ocata)
Assignee: Chris Jones
QA Contact: Asaf Hirshberg
URL: https://api.access.redhat.com/rs/tele...
Whiteboard: abrt_hash:566d6d8d0ad5cef6e984df4fa09...
Depends On: 1558241 1242422 1246291
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-07-27 07:34 UTC by Fabio Massimo Di Nitto
Modified: 2018-03-19 21:16 UTC (History)
18 users (show)

Fixed In Version:
Doc Type: Known Issue
Doc Text:
Pacemaker continuously crashes when the fencing device name and the host name are the same. To avoid this problem, add the "fence-" prefix or the "-fence" suffix to the name of the fencing device. With the names configured like this, the cluster works without errors.
Clone Of: 1246291
Environment:
Last Closed: 2017-05-17 19:23:43 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2017:1245 normal SHIPPED_LIVE Red Hat OpenStack Platform 11.0 Bug Fix and Enhancement Advisory 2017-05-17 23:01:50 UTC

Comment 3 Fabio Massimo Di Nitto 2015-07-27 07:43:01 UTC
Skipping trough the details of the original bug, the way in which ospd is configuring fence devices causes pacemaker to crash.

The root issue is of course in pacemaker and we are working to fix it, BUT we can´t make it in time for OSP7 GA.

The problem is that OSPd is configuring fence devices with a name that matches the hostname. This makes pacemaker crash and fail.

the simplest workaround possible is to simply add a fence-* prefix or *-fence suffix when configuring stonith devices.

Without this workaround and the proper fix, it will be impossible to manage a HA OSP.

Be aware that everything will work just fine after a normal deployment because fence devices are configured after cluster has formed, but everything will explode at the first time one of the nodes is rebooted or restarted.

Comment 4 chris alfonso 2015-08-20 16:34:22 UTC
Moving this to A2 since we don't yet support fence device configuration with OSP-director just yet.

Comment 7 Mike Burns 2016-04-07 20:47:27 UTC
This bug did not make the OSP 8.0 release.  It is being deferred to OSP 10.

Comment 9 Fabio Massimo Di Nitto 2016-08-30 12:30:39 UTC
moving to OSP11 as part of auto-fencing implementation.

Chris, while the pacemaker bug has been fixed, we still want to have a fence-$nodename or $nodename-fence entry when creating stonith services.

Comment 17 Asaf Hirshberg 2017-05-01 08:33:43 UTC
Verified.

Comment 20 errata-xmlrpc 2017-05-17 19:23:43 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2017:1245


Note You need to log in before you can comment on or make changes to this bug.