Bug 1247037 - [new HostSetupNetworks] unmanaged networks handling
[new HostSetupNetworks] unmanaged networks handling
Status: CLOSED DUPLICATE of bug 1167698
Product: ovirt-engine
Classification: oVirt
Component: General (Show other bugs)
---
Unspecified Unspecified
high Severity medium (vote)
: ovirt-3.6.1
: ---
Assigned To: Marcin Mirecki
Pavel Stehlik
network
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-07-27 03:59 EDT by Alona Kaplan
Modified: 2016-02-10 14:17 EST (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-10-26 10:39:38 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Network
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
ylavi: ovirt‑3.6.z?
ylavi: ovirt‑4.0.0?
ylavi: blocker?
ylavi: planning_ack?
ylavi: devel_ack?
ylavi: testing_ack?


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 44083 master MERGED core: update network attachments accordingly when attaching/detaching network to/from cluster Never
oVirt gerrit 46209 master ABANDONED core: do not allow use nic as a slave, when there's unmanaged network on this nic Never

  None (edit)
Description Alona Kaplan 2015-07-27 03:59:25 EDT
Description of problem:

1. When detaching network from cluster- the network attachments of the network are not removed.
2. Any operation with unmanaged networks, except removing it, should be blocked.
(Moving to another nic, adding network to the nic that contains unmanaged network, adding nic with unmanaged network to a bond).

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 1 Alona Kaplan 2015-07-27 04:56:02 EDT
Also attaching a label to nic with unmanaged networks should be blocked.
Comment 2 Alona Kaplan 2015-07-28 08:12:38 EDT
Also, when attaching a network to cluster, in case previously the network was unmanaged on the host. And attachment should be added.
Comment 3 Yaniv Lavi (Dary) 2015-09-07 05:15:21 EDT
should this be MODIFIED?
Comment 4 Dan Kenigsberg 2015-09-10 07:26:03 EDT
I'm afraid not -

2. Any operation with unmanaged networks, except removing it, should be blocked.
(Moving to another nic, adding network to the nic that contains unmanaged network, adding nic with unmanaged network to a bond).

is not implemented yet.
Comment 7 Martin Mucha 2015-09-15 16:24:43 EDT
Current status:
ad 1 — this was already fixed, but due to error in "manage networks" dialog it cannot be verified.

ad 2 — in UI, which uses new command,  it seems that:
• moving is illegal
• adding another network to same nic is illegal
• adding nic which has unmanaged network to bond is illegal.

via old command I did not test it. Should be old command tested and fixed if needed?

via rest & new command:
• moving cannot be performed since unmanaged network does not have relevant network attachment.
• adding another network to nic which contains unmanaged network is allowed
• creating bond using as a slave nic which has unmanaged network is allowed.

--> ie. not speaking about old command, there are two bugs to be solved. Two new validation methods needs to be introduced, I'll solve both using this patch and two distinct changes.
Comment 8 Dan Kenigsberg 2015-09-24 03:37:45 EDT
since sub-issue (1) was solved, we can demote the "blocker" status of this bug.
Comment 9 Red Hat Bugzilla Rules Engine 2015-10-19 06:50:34 EDT
Target release should be placed once a package build is known to fix a issue. Since this bug is not modified, the target version has been reset. Please use target milestone to plan a fix for a oVirt release.
Comment 10 Dan Kenigsberg 2015-10-26 10:39:38 EDT
let us consider sub-issue(2) only once

*** This bug has been marked as a duplicate of bug 1167698 ***

Note You need to log in before you can comment on or make changes to this bug.