Bug 1247068 - [TEXT] Warn the administrator that CD/DVD passthrough is disabled for RHEL7
[TEXT] Warn the administrator that CD/DVD passthrough is disabled for RHEL7
Status: CLOSED CURRENTRELEASE
Product: ovirt-hosted-engine-setup
Classification: oVirt
Component: General (Show other bugs)
1.3.0
x86_64 Linux
unspecified Severity low (vote)
: ovirt-3.6.1
: 1.3.1
Assigned To: Ivan Bulatovic
Nikolai Sednev
: EasyFix
Depends On: 760885
Blocks: 1284979
  Show dependency treegraph
 
Reported: 2015-07-27 05:21 EDT by Ivan Bulatovic
Modified: 2016-02-17 02:18 EST (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-17 02:18:27 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Integration
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
rule-engine: ovirt‑3.6.z+
bmcclain: planning_ack+
sbonazzo: devel_ack+
mavital: testing_ack+


Attachments (Terms of Use)
Warning (771 bytes, patch)
2015-09-21 08:33 EDT, Ivan Bulatovic
no flags Details | Diff


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Bugzilla 760885 None None None Never
oVirt gerrit 46809 master MERGED packaging: setup: add warning for CD passthrough Never
oVirt gerrit 47969 ovirt-hosted-engine-setup-1.3 MERGED packaging: setup: add warning for CD passthrough Never

  None (edit)
Description Ivan Bulatovic 2015-07-27 05:21:13 EDT
Description of problem:

While deploying ovirt-hosted-engine, administrator is asked about the type of VM installation (cdrom, disk, pxe). If cdrom is selected, and information regarding cd/dvd device node provided, during VM startup deployment will fail, without valid information regarding the cause of failure. Log however contains the following:

2015-07-25 16:00:16 DEBUG otopi.plugins.ovirt_hosted_engine_setup.vm.runvm mixins._create_vm:268 {'status': {'message': 'Done', 'code': 0}, 'statsList': [{'status': 'Down', 'exitMessage': "internal error: early end of file from monitor: possible problem:\n2015-07-25T14:00:16.487075Z qemu-kvm: -drive file=/dev/sr0,if=none,id=drive-ide0-1-0,readonly=on,format=raw,serial=: could not open disk image /dev/sr0: Driver 'host_cdrom' is not whitelisted\n", 'vmId': '*', 'exitReason': 1, 'statusTime': '4296047400', 'exitCode': 1}]}


Version-Release number of selected component (if applicable):

ovirt-hosted-engine-setup-1.3.0-0.0.master.20150623153111.git68138d4.el7.noarch

How reproducible:

Always

Steps to Reproduce:
1.Run hosted-engine --deploy
2.select cdrom and provide device node path (ie /dev/sr0)

Actual results:

Deployment fails

Expected results:

Deployment fails with valid info, or administrator should be warned that CD/DVD passthrough is disabled on RHEL7, and that cdrom option will work only if iso file location is provided.

Additional info:
Comment 1 Michal Skrivanek 2015-07-29 07:52:31 EDT
seems HE deployment related, moving to integration
Comment 2 Ivan Bulatovic 2015-09-21 08:33 EDT
Created attachment 1075508 [details]
Warning

Took a shot at it, since it was easier to complain on bz. I'm not sure if this is the place to pop this up, or upon selecting cdrom based installation.

Kind regards,

Ivan
Comment 3 Sandro Bonazzola 2015-09-29 04:44:30 EDT
Ivan thanks for the patch!
Do you mind pushing it into gerrit? See http://www.ovirt.org/Working_with_oVirt_Gerrit for more info.
Feel free to ask on IRC if help is needed with gerrit.
Comment 4 Ivan Bulatovic 2015-09-29 12:43:13 EDT
Pushed it as a draft, thanks Sandro,

Ivan
Comment 5 Red Hat Bugzilla Rules Engine 2015-10-19 06:55:47 EDT
Target release should be placed once a package build is known to fix a issue. Since this bug is not modified, the target version has been reset. Please use target milestone to plan a fix for a oVirt release.
Comment 6 Gil Klein 2016-02-17 02:18:27 EST
This bug was fixed and is slated to be in the upcoming version. As we
are focusing our testing at this phase on severe bugs, this bug was
closed without going through its verification step. If you think this
bug should be verified by QE, please set its severity to high and move
it back to ON_QA

Note You need to log in before you can comment on or make changes to this bug.