Bug 1247087 - Setting keepalive_required option will refuse all the client connections.
Summary: Setting keepalive_required option will refuse all the client connections.
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: libvirt
Version: 7.2
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: rc
: ---
Assignee: Martin Kletzander
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-07-27 10:08 UTC by Fangge Jin
Modified: 2015-11-19 06:49 UTC (History)
4 users (show)

Fixed In Version: libvirt-1.2.17-5.el7
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-11-19 06:49:16 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2015:2202 0 normal SHIPPED_LIVE libvirt bug fix and enhancement update 2015-11-19 08:17:58 UTC

Description Fangge Jin 2015-07-27 10:08:12 UTC
Description of problem:
When setting keepalive_required=1, libvirtd will refuse all the clients even if the client supports keepalive.

Version-Release number of selected component :
libvirt-1.2.17-2.el7.x86_64

How reproducible:
100%

Steps to Reproduce:
1.Set keepalive_required=1 in libvirtd.conf on host A, restart libvirtd service.

2.Connect to the libvirtd of host A:
# virsh -c qemu+tcp://10.66.6.6/system
error: failed to connect to the hypervisor
error: operation failed: keepalive support is required to connect


Actual results:
As step2, libvirtd refused the client connection.

Expected results:
As virsh client supports replying for server keepalives, it should connect successfully.

Comment 2 Martin Kletzander 2015-07-31 12:52:02 UTC
Patch proposed upstream:

https://www.redhat.com/archives/libvir-list/2015-July/msg00738.html

Comment 4 Martin Kletzander 2015-08-10 15:28:15 UTC
Fixed upstream by v1.2.18-61-ga8743c39389b:

commit a8743c39389b76897811f60dcd8485cd51d76f02
Author: Martin Kletzander <mkletzan@redhat.com>
Date:   Mon Jul 20 14:51:24 2015 +0200

    rpc: Remove keepalive_required option

Comment 6 zhenfeng wang 2015-08-24 09:35:06 UTC
Verify this bug with libvirt-1.2.17-6.el7, could found the clear explanation that the keepalive_required option has been removed in libvirtd.conf, also found the corresponding code has been disabled, so we could verify this bug right now. 

# These configuration options are no longer used.  There is no way to
# restrict such clients from connecting since they first need to
# connect in order to ask for keepalive.
#
#keepalive_required = 1
#admin_keepalive_required = 1

Comment 8 errata-xmlrpc 2015-11-19 06:49:16 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-2202.html


Note You need to log in before you can comment on or make changes to this bug.