Bug 1247150 - avc: denied, after running hostnamectl on s390x
avc: denied, after running hostnamectl on s390x
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: systemd (Show other bugs)
7.3
s390x Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: systemd-maint
Branislav Blaškovič
:
Depends On:
Blocks: 1393867 1400961 74systemd
  Show dependency treegraph
 
Reported: 2015-07-27 09:01 EDT by Branislav Blaškovič
Modified: 2016-12-23 09:28 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-12-23 09:28:05 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Branislav Blaškovič 2015-07-27 09:01:38 EDT
Description of problem:
hostnamectl generates AVC denial on s390x

Version-Release number of selected component (if applicable):
systemd-219-8.el7.s390x


Steps to Reproduce:
1. Run /CoreOS/systemd/Sanity/hostnamectl  on s390x

Actual results:
time->Mon Jul 27 08:53:18 2015
type=SYSCALL msg=audit(1438001598.519:55): arch=80000016 syscall=5 success=no exit=-13 a0=2aa007492f4 a1=80000 a2=1b6 a3=80000 items=0 ppid=1 pid=12428 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=4294967295 comm="systemd-hostnam" exe="/usr/lib/systemd/systemd-hostnamed" subj=system_u:system_r:systemd_hostnamed_t:s0 key=(null)
type=AVC msg=audit(1438001598.519:55): avc:  denied  { read } for  pid=12428 comm="systemd-hostnam" name="sysinfo" dev="proc" ino=4026531902 scontext=system_u:system_r:systemd_hostnamed_t:s0 tcontext=system_u:object_r:sysctl_t:s0 tclass=file

Expected results:
No denials

Additional info:
Beaker run: https://beaker.engineering.redhat.com/recipes/2108210
Comment 2 Michal Sekletar 2016-01-12 13:37:16 EST
Is this still reproducible with newest versions of SELinux policy and systemd?
Comment 3 Branislav Blaškovič 2016-01-13 07:00:44 EST
selinux-policy-3.13.1-60.el7.noarch
systemd-219-19.el7_2.3.s390x


time->Fri Jan  8 13:23:38 2016
type=SYSCALL msg=audit(1452277418.115:101): arch=80000016 syscall=5 success=no exit=-13 a0=2aa0019e2cc a1=80000 a2=1b6 a3=80000 items=0 ppid=1 pid=11276 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=4294967295 comm="systemd-hostnam" exe="/usr/lib/systemd/systemd-hostnamed" subj=system_u:system_r:systemd_hostnamed_t:s0 key=(null)
type=AVC msg=audit(1452277418.115:101): avc:  denied  { read } for  pid=11276 comm="systemd-hostnam" name="sysinfo" dev="proc" ino=4026531902 scontext=system_u:system_r:systemd_hostnamed_t:s0 tcontext=system_u:object_r:sysctl_t:s0 tclass=file
Comment 5 Jan Synacek 2016-11-10 08:30:58 EST
Needs to be retested with 219-30.
Comment 6 Michal Sekletar 2016-12-23 09:28:05 EST
This seems to be fixed now.

https://beaker.engineering.redhat.com/jobs/1645669

Brano, please double check and reopen if necessary.

Note You need to log in before you can comment on or make changes to this bug.