Bug 1247175 - Need newer ruby for RHEL 5.x systems to work with puppet facter
Need newer ruby for RHEL 5.x systems to work with puppet facter
Status: CLOSED ERRATA
Product: Red Hat Satellite 6
Classification: Red Hat
Component: SCAP Plugin (Show other bugs)
Unspecified
Unspecified Unspecified
unspecified Severity medium (vote)
: 6.1.6
: --
Assigned To: Shlomi Zadok
Corey Welton
http://projects.theforeman.org/issues...
: Reopened, Triaged
: 1232023 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-07-27 09:38 EDT by Og Maciel
Modified: 2017-02-23 14:49 EST (History)
13 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
The SCAP client would not handle arrays properly from Red Hat Enterprise Linux 5 machines due to older Ruby versions. The code was updated to support the arrays from older Ruby versions.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-11 11:23:14 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Knowledge Base (Solution) 2153041 None None None 2016-02-05 06:21 EST

  None (edit)
Description Og Maciel 2015-07-27 09:38:54 EDT
Description of problem:

The custom fact provided by openscap converts an array to a hash using
Hash, which isn't supported on Ruby 1.8.5.

1.8.5:

 1.8.5-p231 :003 > Hash[[['foo', 'bar']]]
 ArgumentError: odd number of arguments for Hash
 from (irb):3:in `[]'
 from (irb):3
 from :0

Newer:

 irb(main):001:0> Hash[[['foo', 'bar']]]
 => {"foo"=>"bar"}


Version-Release number of selected component (if applicable):

* Satellite 6.1.1 SNAP 14

How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 5 Shlomi Zadok 2015-10-25 09:54:40 EDT
Created redmine issue http://projects.theforeman.org/issues/12304 from this bug
Comment 7 Bryan Kearney 2015-10-25 10:02:39 EDT
Upstream bug component is SCAP Plugin
Comment 10 Shlomi Zadok 2015-11-17 02:46:34 EST
*** Bug 1232023 has been marked as a duplicate of this bug. ***
Comment 14 Og Maciel 2016-01-07 13:53:24 EST
To verify:

* Sync all of RHEL 5Server and 5.11 RPMs from CDN
* Create a custom product and synchronize the Tools channel for RHEL 5 x86_64 using the internal URL usually provided with a new build
* Create a content view and add these repositories to it
* Publish the content view
* Create an activation key, associating it to this content view
* Provision a new RHEL 5 x86_64 Host, perhaps using a Host Group + a libVirt Compute Resource
* Check that the provisioned Host shows/generates Puppet reports
Comment 15 Corey Welton 2016-01-15 18:10:28 EST
Verified in 6.1.6 Compose #5

Sample content from a RHEL5 host puppet report:



Level	Resource	message
info	Puppet	Retrieving plugin
info	Puppet	Caching certificate_revocation_list for ca
notice	/File[/var/lib/puppet/lib/puppet]/ensure	created
notice	/File[/var/lib/puppet/lib/puppet/provider]/ensure	created
notice	/File[/var/lib/puppet/lib/puppet/provider/file_line]/ensure	created
notice	/File[/var/lib/puppet/lib/puppet/parser]/ensure	created
notice	/File[/var/lib/puppet/lib/puppet/parser/functions]/ensure	created
notice	/File[/var/lib/puppet/lib/puppet/parser/functions/ensure_packages.rb]/ensure	defined content as '{md5}fbed5c0c9bf82b7746e01f15f89d184f'
notice	/File[/var/lib/puppet/lib/puppet/parser/functions/validate_hash.rb]/ensure	defined content as '{md5}e9cfaca68751524efe16ecf2f958a9a0'
notice	/File[/var/lib/puppet/lib/puppet/parser/functions/count.rb]/ensure	defined content as '{md5}9eb74eccd93e2b3c87fd5ea14e329eba'
notice	/File[/var/lib/puppet/lib/puppet/parser/functions/validate_bool.rb]/ensure	defined content as '{md5}a712634a000024398b3c6cd4ecc46463'
notice	/File[/var/lib/puppet/lib/puppet/parser/functions/get_module_path.rb]/ensure	defined content as '{md5}d4bf50da25c0b98d26b75354fa1bcc45'
notice	/File[/var/lib/puppet/lib/puppet/parser/functions/is_ip_address.rb]/ensure	defined content as '{md5}a714a736c1560e8739aaacd9030cca00'
notice	/File[/var/lib/puppet/lib/puppet/parser/functions/is_numeric.rb]/ensure	defined content as '{md5}93ddc9d4c0834a5e5e0562d7b3cdce91'
notice	/File[/var/lib/puppet/lib/puppet/parser/functions/delete.rb]/ensure	defined content as '{md5}96e569dac96b8c9387e9303445d73048'
notice	/File[/var/lib/puppet/lib/puppet/parser/functions/is_domain_name.rb]/ensure	defined content as '{md5}cf72726c0fec831eb703ec9deea739eb'
notice	/File[/var/lib/puppet/lib/puppet/parser/functions/has_ip_address.rb]/ensure	defined content as '{md5}ee207f47906455a5aa49c4fb219dd325'
notice	/File[/var/lib/puppet/lib/puppet/parser/functions/validate_absolute_path.rb]/ensure	defined content as '{md5}385137ac24a2dec6cecc4e6ea75be442'
notice	/File[/var/lib/puppet/lib/puppet/parser/functions/has_key.rb]/ensure	defined content as '{md5}7cd9728c38f0b0065f832dabd62b0e7e'
Comment 18 errata-xmlrpc 2016-01-21 02:42:13 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:0052
Comment 20 Bryan Kearney 2016-02-05 08:03:59 EST
Moving to POST since upstream bug http://projects.theforeman.org/issues/12304 has been closed
Comment 22 errata-xmlrpc 2016-02-11 11:23:14 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:0052

Note You need to log in before you can comment on or make changes to this bug.