Bug 1247181 - Failed to deploy HE on RHEL 7.1 host with [ ERROR ] Failed to execute stage 'Misc configuration': Cannot acquire host id: ('d3dbdbc5-958e-47ae-aebb-0f2c1b2097f5', SanlockException(19, 'Sanlock lockspace add failure', 'No such device'))
Failed to deploy HE on RHEL 7.1 host with [ ERROR ] Failed to execute stage '...
Status: CLOSED DUPLICATE of bug 1242448
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-hosted-engine-setup (Show other bugs)
3.6.3
x86_64 Linux
unspecified Severity urgent
: ---
: ---
Assigned To: Sandro Bonazzola
meital avital
integration
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-07-27 09:58 EDT by Nikolai Sednev
Modified: 2015-07-28 04:06 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-07-28 04:06:12 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
answerfile (3.06 KB, text/plain)
2015-07-27 09:58 EDT, Nikolai Sednev
no flags Details
all logs (26.90 KB, application/x-gzip)
2015-07-27 10:02 EDT, Nikolai Sednev
no flags Details

  None (edit)
Description Nikolai Sednev 2015-07-27 09:58:52 EDT
Created attachment 1056582 [details]
answerfile

Description of problem:
Failed to deploy HE on RHEL 7.1 host with [ ERROR ] Failed to execute stage 'Misc configuration': Cannot acquire host id: ('d3dbdbc5-958e-47ae-aebb-0f2c1b2097f5', SanlockException(19, 'Sanlock lockspace add failure', 'No such device'))     

Version-Release number of selected component (if applicable):
[root@alma02 ~]# rpm -qa vdsm* libvirt* qemu* sanlock* mom* ovirt* gluster*
libvirt-daemon-driver-nodedev-1.2.8-16.el7_1.3.x86_64
mom-0.4.5-2.el7.noarch
ovirt-hosted-engine-setup-1.3.0-0.0.master.20150623153111.git68138d4.el7.noarch
vdsm-xmlrpc-4.17.0-1054.git562e711.el7.noarch
libvirt-client-1.2.8-16.el7_1.3.x86_64
libvirt-daemon-config-nwfilter-1.2.8-16.el7_1.3.x86_64
libvirt-daemon-driver-storage-1.2.8-16.el7_1.3.x86_64
libvirt-daemon-kvm-1.2.8-16.el7_1.3.x86_64
vdsm-4.17.0-1054.git562e711.el7.noarch
sanlock-python-3.2.2-2.el7.x86_64
ovirt-host-deploy-1.4.0-0.0.master.20150617062825.git06a8f80.el7.noarch
qemu-kvm-common-ev-2.1.2-23.el7_1.3.1.x86_64
glusterfs-client-xlators-3.7.2-3.el7.x86_64
glusterfs-cli-3.7.2-3.el7.x86_64
vdsm-python-4.17.0-1054.git562e711.el7.noarch
ovirt-engine-sdk-python-3.6.0.0-0.15.20150625.gitfc90daf.el7.centos.noarch
qemu-kvm-ev-2.1.2-23.el7_1.3.1.x86_64
glusterfs-server-3.7.2-3.el7.x86_64
libvirt-daemon-1.2.8-16.el7_1.3.x86_64
libvirt-lock-sanlock-1.2.8-16.el7_1.3.x86_64
libvirt-daemon-driver-secret-1.2.8-16.el7_1.3.x86_64
libvirt-daemon-driver-network-1.2.8-16.el7_1.3.x86_64
ovirt-release-master-001-0.9.master.noarch
vdsm-gluster-4.17.0-1054.git562e711.el7.noarch
sanlock-3.2.2-2.el7.x86_64
vdsm-infra-4.17.0-1054.git562e711.el7.noarch
glusterfs-3.7.2-3.el7.x86_64
glusterfs-fuse-3.7.2-3.el7.x86_64
glusterfs-geo-replication-3.7.2-3.el7.x86_64
ovirt-vmconsole-1.0.0-0.0.master.20150616120945.gitc1fb2bd.el7.noarch
libvirt-daemon-driver-nwfilter-1.2.8-16.el7_1.3.x86_64
libvirt-daemon-driver-interface-1.2.8-16.el7_1.3.x86_64
libvirt-daemon-driver-qemu-1.2.8-16.el7_1.3.x86_64
sanlock-lib-3.2.2-2.el7.x86_64
glusterfs-libs-3.7.2-3.el7.x86_64
qemu-img-ev-2.1.2-23.el7_1.3.1.x86_64
vdsm-cli-4.17.0-1054.git562e711.el7.noarch
vdsm-jsonrpc-4.17.0-1054.git562e711.el7.noarch
ovirt-hosted-engine-ha-1.3.0-0.0.master.20150615153650.20150615153645.git5f8c290.el7.noarch
libvirt-python-1.2.8-7.el7_1.1.x86_64
glusterfs-api-3.7.2-3.el7.x86_64
vdsm-yajsonrpc-4.17.0-1054.git562e711.el7.noarch

How reproducible:
100%

Steps to Reproduce:
1.Reprovision host to RHEL7.1 Linux version 3.10.0-229.9.1.el7.x86_64 (mockbuild@x86-021.build.eng.bos.redhat.com) (gcc version 4.8.3 20140911 (Red Hat 4.8.3-9) (GCC) ) #1 SMP Sat Jul 4 17:21:43 EDT 2015
2.Install ovirt-hosted-engine-setup
3.hosted-engine --deploy on nfs SD for HE.

Actual results:
[ ERROR ] Failed to execute stage 'Misc configuration': Cannot acquire host id: ('d3dbdbc5-958e-47ae-aebb-0f2c1b2097f5', SanlockException(19, 'Sanlock lockspace add failure', 'No such device'))            

Expected results:
Should succeed

Additional info:
logs from host attached
Comment 1 Nikolai Sednev 2015-07-27 10:02:35 EDT
Created attachment 1056583 [details]
all logs
Comment 2 Nikolai Sednev 2015-07-27 11:00:27 EDT
As workaround I've used  setenforce 0 and then deployment passed OK.
Comment 3 Simone Tiraboschi 2015-07-28 04:06:12 EDT

*** This bug has been marked as a duplicate of bug 1242448 ***

Note You need to log in before you can comment on or make changes to this bug.